Opened 6 years ago

Closed 3 years ago

#1863 closed defect (worksforme)

DBMI Protocol Error in v.extract

Reported by: dkavanagh Owned by: grass-dev@…
Priority: normal Milestone: 7.0.5
Component: Vector Version: svn-trunk
Keywords: sqlite, dbmi, v.extract Cc: dkavanagh
CPU: x86-64 Platform: MSWindows 7

Description

I am getting a DBMI Protocol error in v.extract when I query a field value that is equal to 10 (e.g. HCA_ID=10). The exact command is:

v.extract -t --overwrite input=cores type=area where=HCA_ID=10 output=core

If I filter for 9, 11, 20 or 100 the problem does not occur.

I opened the sqlite database directly and queried it. No errors occurred. The field type is integer.

I originally encountered the problem when I ran the v.extract command in a Python script. The script hangs and does not report an error. You have to kill the sqlite exe to free the file lock.

Change History (6)

comment:1 Changed 6 years ago by dkavanagh

Cc: dkavanagh added
CPU: Unspecifiedx86-64

comment:2 Changed 6 years ago by dkavanagh

Keywords: sqlite dbmi v.extract added

comment:3 in reply to:  description Changed 6 years ago by neteler

Keywords: sqlite dbmi v.extractsqlite, dbmi, v.extract

Replying to dkavanagh:

I am getting a DBMI Protocol error in v.extract

Please post also the error here.

And, do you use a recent GRASS 7 snapshot?

comment:4 Changed 6 years ago by dkavanagh

On further testing the problem is not due to the number 10 but its row position, i.e. row 10. A colleague, working with a different input, encounters the same issue once row 10 is queried. We can select above and below but not row 10 itself.

The data is imported from a shape file using v.in.ogr. Strangely, I cannot use the same name when importing, it just hangs. Instead of using - v.in.ogr dsn=cores.shp output=cores I have to use - v.in.ogr dsn=cores.shp output=gcores

The error is - dbmi: Protocol error ERROR: Unable select records from table <gcores> The error is not reported when it is called within a python script.

I just tested today with the most recent build (WinGRASS-7.0.svn-r54762-480-Setup). The problem still exists. It did not occur in a build from May of last year (WinGRASS-7.0.svn-r51660-239-Setup.exe).

comment:5 Changed 3 years ago by martinl

Milestone: 7.0.07.0.5

comment:6 Changed 3 years ago by martinl

Resolution: worksforme
Status: newclosed

No activity last 4 years, closing, feel free to reopen if needed.

Note: See TracTickets for help on using tickets.