Opened 11 years ago

Closed 5 years ago

#1813 closed defect (worksforme)

RST lib quad_divide_data calls exit with 0

Reported by: marisn Owned by: grass-dev@…
Priority: normal Milestone: 7.0.7
Component: Raster Version: svn-trunk
Keywords: Cc:
CPU: Unspecified Platform: Unspecified

Description

RST lib in quad_divide_data() calls exit with argument 0.

First - how a failure can be 0 (success)?

Second - #1598 This looks like one of those places, where G_fatal_error() is more appropriate.

Third - this exit() prevents interpolation when data points are arranged in a stripe (filling a hole between two map sheets). Is it really necessary to EXIT here instead of just printing a warning?

http://trac.osgeo.org/grass/browser/grass/trunk/lib/rst/data/dataquad.c#L214

Attachments (1)

rst_fail_data.zip (92.7 KB ) - added by marisn 11 years ago.
Data to display interpolation failure

Download all attachments as: .zip

Change History (6)

by marisn, 11 years ago

Attachment: rst_fail_data.zip added

Data to display interpolation failure

comment:1 by marisn, 11 years ago

Attached file contains a 3D shapefile with data stripe and hole in the middle. The goal is to interpolate data from surrounding points to fill the hole.

Unzip file, create a new location based on provided file. Remove imported vector file and import it again this time with -z option (see bug #1822).

Set region and run interpolation:

g.region -a res=20
v.surf.rst -z input=interpolate_this layer=1 elev=filled_hole

comment:2 by martinl, 8 years ago

Milestone: 7.0.07.0.5

comment:3 by neteler, 7 years ago

Milestone: 7.0.57.0.6

comment:4 by neteler, 6 years ago

Milestone: 7.0.67.0.7

comment:5 by martinl, 5 years ago

Resolution: worksforme
Status: newclosed

unable to reproduce

Note: See TracTickets for help on using tickets.