Opened 8 years ago

Closed 7 years ago

#1766 closed defect (fixed)

unable to save display of d.rast.num

Reported by: cmbarton Owned by: grass-dev@…
Priority: major Milestone: 7.0.0
Component: wxGUI Version: svn-trunk
Keywords: d.rast.num Cc:
CPU: Unspecified Platform: Unspecified

Description

I just learned that I can no longer save a display of cell number using d.rast.num in GRASS 7. I know this worked for a talk I gave earlier this year. Now it does not.

I get a bogus error about the region being too large. But the region it gives is NOT the display region, the computational region (matches the display region in this case), or even the size of the raster map.

Here is an example using the elevation raster from the sc_08 data set. I've reduced the computational region and display region (and have them matched) in order to display cell numbers. And the display is constrained to the computational region (it must be to display cell numbers). So here is what happens. Note the size of the region and the error.

Command 'd.rast.num map=movwin_elev_max@spatialtech2012'
failed
Details: Current region size: 722 rows X 973 cols
Your current region setting may be too large. Cells
displayed on your graphics window may be too small for cell
category number to be visible.
(Mon Oct 22 22:13:51 2012)                                                      
g.region -p                                                                     
projection: 99 (Lambert Conformal Conic)
zone:       0
datum:      nad83
ellipsoid:  a=6378137 es=0.006694380022900787
north:      224062.105333
south:      223987.185037
west:       633201.322138
east:       633302.184365
nsres:      10.70289943
ewres:      10.0862227
rows:       7
cols:       10
cells:      70

Change History (6)

comment:1 Changed 8 years ago by annakrat

Please try r53527.

comment:2 Changed 7 years ago by neteler

Summary: unable to save display of g.rast.numunable to save display of d.rast.num

Currently d.rast.num in GRASS 7 does not output anything in wx0:

GRASS 7.0.svn (nc_spm_08):~ > d.rast.num testascii
GRASS 7.0.svn (nc_spm_08):~ > ERROR: Rendering failed. Details: File </home/neteler/grassdata/nc_spm_08/neteler/.tmp/north.localdomain/24970.0.ppm> not found

comment:3 Changed 7 years ago by neteler

Component: DefaultwxGUI
Keywords: d.rast.num added; r.rast.num removed

comment:4 Changed 7 years ago by mlennert

I cannot reproduce this. I can display numbers with d.rast.num, using the following region and save the display to a png file.

g.region -p                                                                     
projection: 99 (Lambert Conformal Conic)
zone:       0
datum:      nad83
ellipsoid:  a=6378137 es=0.006694380022900787
north:      226920
south:      226720
west:       632710
east:       633050
nsres:      10
ewres:      10
rows:       20
cols:       34
cells:      680

Can anyone confirm the error ?

comment:5 in reply to:  4 Changed 7 years ago by martinl

Replying to mlennert:

I cannot reproduce this. I can display numbers with d.rast.num, using the following region and save the display to a png file.

Testing with North Carolina dataset ('elevation'), displaying cell numbers works for me (Debian GNU/Linux).

comment:6 Changed 7 years ago by cmbarton

Resolution: fixed
Status: newclosed

Just tested in my version of GRASS 7 compiled a couple weeks back. Numbers display AND I can save the display to a PNG. This works in both the S Carolina test data and a latlon DEM I tried. So AFAIC, we can close this. I'll do so since others report it fixed too.

Michael

Note: See TracTickets for help on using tickets.