Opened 7 years ago

Closed 7 years ago

#1709 closed defect (duplicate)

New PC Win Win7 64 bit software doenst start

Reported by: devnull007 Owned by: grass-dev@…
Priority: critical Milestone: 6.4.3
Component: Default Version: 6.4.1
Keywords: crash, showstopper Cc:
CPU: x86-64 Platform: Unspecified

Description

Grass GIS does not start. It gives error of missing msvcp71.dll. Ive tried to install all .net packes from tnhe link given here in the beginning. http://grass.fbk.eu/grass64/binary/mswindows/ which points to http://msdn.microsoft.com/en-us/vstudio/aa496123 unfortunately after installing all that stuff. Grass GIS is still not running. Just disappointing for such a large project to give so poor documentation. Links in other bug reports given also didn't work. Only source for the dll may be dll-file.com but I'm NOT willing to download dlls from somewhere else where it can't be trusted. So please give a download possibility directly from microsoft. Else your product is broken beyond any usability.

Change History (3)

comment:1 in reply to:  description Changed 7 years ago by hellik

Replying to devnull007:

Grass GIS does not start. It gives error of missing msvcp71.dll. Ive tried to install all .net packes from tnhe link given here in the beginning. http://grass.fbk.eu/grass64/binary/mswindows/ which points to http://msdn.microsoft.com/en-us/vstudio/aa496123 unfortunately after installing all that stuff. Grass GIS is still not running. Just disappointing for such a large project to give so poor documentation. Links in other bug reports given also didn't work. Only source for the dll may be dll-file.com but I'm NOT willing to download dlls from somewhere else where it can't be trusted. So please give a download possibility directly from microsoft. Else your product is broken beyond any usability.

see also here:

https://trac.osgeo.org/grass/ticket/1428 https://trac.osgeo.org/grass/ticket/1428#comment:8

microsoft doesn't ship their runtimes with the different windows versions.

any help/hints to solve this issue are welcome.

Helmut

comment:2 in reply to:  description Changed 7 years ago by neteler

Replying to devnull007:

Grass GIS does not start. It gives error of missing msvcp71.dll.

...

Only source for the dll may be dll-file.com but I'm NOT willing to download dlls from somewhere else where it can't be trusted. So please give a download possibility directly from microsoft.

I agree but here an answer from the Microsoft Support:

http://answers.microsoft.com/en-us/windows/forum/windows_other-windows_update/msvcp71dll/bf7a2488-21d8-47af-9e3b-800d3683bc89 "2. Download the DLL from the Internet or copy it from another PC with same configuration as your PC and register the file on the system:"

... an amazing answer.

In the same thread someone suggests to install "Microsoft® Visual Studio® .NET™ 2003 Service Pack 1".

See also:

http://www.addictivetips.com/windows-tips/fix-msvcp71-dll-and-msvcr71-dll-missing-error-in-windows-7/

The Microsoft forum is full of this problem, it appears to be a Microsoft problem:

http://support.microsoft.com/search/default.aspx?query=msvcp71.dll&catalog=LCID%3D1033&mode=r

comment:3 Changed 7 years ago by hamish

Resolution: duplicate
Status: newclosed

dupe of #1428. continued there...

Note: See TracTickets for help on using tickets.