Opened 7 years ago

Closed 7 years ago

#1666 closed defect (fixed)

v.proj - Error in pj_do_transform

Reported by: spiderplant0 Owned by: grass-dev@…
Priority: normal Milestone: 6.4.3
Component: Vector Version: 6.4.2
Keywords: Cc:
CPU: x86-64 Platform: MSWindows 7

Description

Consider this data organization...

e:\work\grass\GB\mapset1
e:\work\grass\UK_EPSG900913\mapset1

I.e. 'mapset1' folders contain the 'vector' and 'dbf' directories etc.

And I have two locations 'GB' and 'UK_EPSG900913' The projections are set to OSGB36 and epsg900913 respectively.

I have a map in the 'GB' location that I wish to re-project to epsg900913. So I choose the location as 'UK_EPSG900913' and 'mapset1' and then I run this command...

v.proj input=scot location=GB mapset=mapset1 output=scot1

It works on Linux but when I run this on windows I get the error...

Reprojecting primitives:
pj_transform() failed: failed to load datum shift file
ERROR: Error in pj_do_transform

Tested on..

Windows 7 64-bit with GRASS 6.4.2 32-bit - get error

Ubuntu 12.04 64-bit with GRASS 6.4.2 64-bit - OK

Ubuntu 11.10 32-bit with GRASS 6.4.1 32-bit - OK

Change History (1)

comment:1 Changed 7 years ago by neteler

Resolution: fixed
Status: newclosed

The similar ticket #1189 has been fixed. Assuming that it applies to this ticket, too: closing. Feel free to reopen if needed.

Note: See TracTickets for help on using tickets.