Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1590 closed defect (fixed)

new vector map crashing GUI in 6.4.3 svn

Reported by: cmbarton Owned by: grass-dev@…
Priority: normal Milestone: 6.4.3
Component: wxGUI Version: svn-releasebranch64
Keywords: digitizer Cc:
CPU: Unspecified Platform: Unspecified

Description

I just compiled 6.4.3 svn and tested. The digitizer crashes the entire GUI if you try to create a new vector map. The empty vector is created. I fixed the topology and tried to digitize it again, and it crashed the GUI again.

Digitizing on an existing map works fine.

Change History (4)

comment:1 Changed 8 years ago by annakrat

Bug is caused by running db.execute with input='-' option in gui_core/dialogs in CreateNewVector, which works for 6.5 but not 6.4 (difference is in db/base/execute.c line 49). I removed input='-' (r50932), another option is to synchronize execute.c.

Anna

comment:2 Changed 8 years ago by cmbarton

Thanks. I'll try again when I get a chance to compile.

Michaesl

comment:3 Changed 8 years ago by cmbarton

Resolution: fixed
Status: newclosed

This is fixed. Closing.

Michael

comment:4 in reply to:  1 Changed 8 years ago by martinl

Replying to annakrat:

Bug is caused by running db.execute with input='-' option in gui_core/dialogs in CreateNewVector, which works for 6.5 but not 6.4 (difference is in db/base/execute.c line 49). I removed input='-' (r50932), another option is to synchronize execute.c.

just quick note, I would prefer to synchronize usage of db.execute (G65 X G64) rather than just fixing wxGUI code.

Note: See TracTickets for help on using tickets.