Opened 11 years ago

Closed 11 years ago

#1538 closed defect (fixed)

wxGUI: Common raster formats importer python error for single file

Reported by: neteler Owned by: grass-dev@…
Priority: normal Milestone: 6.4.2
Component: wxGUI Version: 6.4.2 RCs
Keywords: Cc: martinl
CPU: x86-64 Platform: Linux

Description

When importing with File -> Import -> Common raster formats -> File (directory works fine) -> /home/neteler/data/satellite/landsat_etna/srtm_etna_90m_UTM33.tif

I get this error

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-
packages/wx-2.8-gtk2-unicode/wx/lib/filebrowsebutton.py",
line 140, in OnChanged

self.changeCallback(evt)
  File "/home/neteler/grass64/dist.x86_64-unknown-linux-
gnu/etc/wxpython/gui_modules/gselect.py", line 1439, in
OnSetDsn

self._reloadLayers()
  File "/home/neteler/grass64/dist.x86_64-unknown-linux-
gnu/etc/wxpython/gui_modules/gselect.py", line 1457, in
_reloadLayers

grassName = utils.GetValidLayerName(baseName.split('.',
-1)[0])
  File "/home/neteler/grass64/dist.x86_64-unknown-linux-
gnu/etc/wxpython/gui_modules/utils.py", line 188, in
GetValidLayerName

if not (retName[0] >= 'A' and retName[0] <= 'Z') and \
IndexError
:
string index out of range
(Mon Jan 16 15:41:44 2012)                                                      
r.in.gdal input=/home/neteler/data/satellite/landsat_etna/srtm_etna_90m_UTM33.tif output=srtm_etna_90m_UTM33
Projection of input dataset and current location appear to match
r.in.gdal complete. Raster map <srtm_etna_90m_UTM33> created.
(Mon Jan 16 15:41:45 2012) Command finished (0 sec)                             

The dialog crashes but the map is imported.

Change History (2)

comment:1 by martinl, 11 years ago

Cc: martinl added

Testing 6.4.2svn I am unable to reproduce this error.

comment:2 by neteler, 11 years ago

Resolution: fixed
Status: newclosed

Works in current 6.4.svn version again. Closing.

Note: See TracTickets for help on using tickets.