Opened 10 years ago

Closed 10 years ago

#1531 closed defect (fixed)

bug in cartographic composer

Reported by: lucadelu Owned by: grass-dev@…
Priority: major Milestone: 6.4.2
Component: wxGUI Version: unspecified
Keywords: ps.map, cartographic composer Cc: annakrat
CPU: All Platform: All

Description

In the cartographic composer it's impossible to set vector properties, show preview and generate an image if the language is different from English. This is the error

GUI D1/5: gselect.VectorDBInfo._DescribeTables(): table=fiumi driver=sqlite database=/grassdata/piemonte_UTM32wgs84/PERMANENT/sqlite.db
Traceback (most recent call last):
  File "/home/luca/compilati/grass64/dist.x86_64-unknown-linux-gnu/etc/wxpython/gui_modules/psmap_dialogs.py", line 2836, in OnProperties
    vectors = self.vectorList, tmpSettings = self.tmpDialogDict[id])
  File "/home/luca/compilati/grass64/dist.x86_64-unknown-linux-gnu/etc/wxpython/gui_modules/psmap_dialogs.py", line 3008, in __init__
    self.ColorsPanel = selectPanel[self.type][0](notebook)
KeyError: u'linee'

The problem is at lines 3005 and 3008

        selectPanel = { 'points': [self._ColorsPointAreaPanel, self._StylePointPanel], 
                        'lines': [self._ColorsLinePanel, self._StyleLinePanel], 
                        'areas': [self._ColorsPointAreaPanel, self._StyleAreaPanel]}
        self.ColorsPanel = selectPanel[self.type][0](notebook)

because

selectPanel[self.type][0](notebook)

returns the translate string and this is missing from the selectPanel dictionary.

The same problem exists also in grass65 and grass7.

Change History (4)

comment:1 by annakrat, 10 years ago

Cc: annakrat added

Thanks for the detailed description. Please confirm if it is fixed (r50111) in grass 7.

Anna

in reply to:  1 ; comment:2 by lucadelu, 10 years ago

Replying to annakrat:

Thanks for the detailed description. Please confirm if it is fixed (r50111) in grass 7.

Anna

Yes it is fixed, please backport to grass 6.4.3

in reply to:  2 comment:3 by lucadelu, 10 years ago

Replying to lucadelu:

Yes it is fixed, please backport to grass 6.4.3

Sorry of course 6.4.2

comment:4 by annakrat, 10 years ago

Resolution: fixed
Status: newclosed

Sorry for the delay, it is backported now. Closing the ticket.

Anna

Note: See TracTickets for help on using tickets.