Opened 10 years ago

Closed 10 years ago

#1526 closed defect (fixed)

"Diplay/update attributes" can freeze GUI

Reported by: artegion Owned by: martinl
Priority: blocker Milestone: 6.4.2
Component: wxGUI Version: 6.4.2 RCs
Keywords: Cc: grass-dev@…
CPU: x86-64 Platform: MSWindows XP

Description

Digitize "Diplay/update attributes" button (wxPython)

if value type is incorrect (example 'a' in [integer] field ) pressing Submit button freezes wxPython GUI

Change History (7)

comment:1 by martinl, 10 years ago

Cc: grass-dev@… added
Milestone: 6.4.26.4.3
Owner: changed from grass-dev@… to martinl

Could you try GRASS 6.5 from (1) - this bug has been probably fixed in r50007?

[1] http://wingrass.fsv.cvut.cz/grass65/

comment:2 by martinl, 10 years ago

Milestone: 6.4.36.4.2

comment:3 by martinl, 10 years ago

It's freezing on gcmd (RunCommand called from dbm_dialogs)

in reply to:  1 ; comment:4 by artegion, 10 years ago

Yes, with 6.5 it works.

(defect with multiple layer ( Ticket #1522 ) remains but it is another thread...)

Replying to martinl:

Could you try GRASS 6.5 from (1) - this bug has been probably fixed in r50007?

[1] http://wingrass.fsv.cvut.cz/grass65/

in reply to:  4 ; comment:5 by martinl, 10 years ago

Replying to artegion:

Yes, with 6.5 it works.

it's just the coincidence, in G65 simply command which doesn't terminate is not called. The SQL statement is checked first and then the command (db.execute sql=) is launched. The problem is that the process launched doesn't terminate in this case.

in reply to:  5 ; comment:6 by martinl, 10 years ago

Replying to martinl:

Replying to artegion:

Yes, with 6.5 it works.

it's just the coincidence, in G65 simply command which doesn't terminate is not called. The SQL statement is checked first and then the command (db.execute sql=) is launched. The problem is that the process launched doesn't terminate in this case.

probably not related to wxGUI at all, hopefully fixed in r50051. Can you confirm it?

in reply to:  6 comment:7 by martinl, 10 years ago

Resolution: fixed
Status: newclosed

probably not related to wxGUI at all, hopefully fixed in r50051. Can you confirm it?

tested with (1), seems to work. Closing this ticket, feel free to re-open if needed.

(1) http://wingrass.fsv.cvut.cz/grass64/WinGRASS-6.4.SVN-r50051-1-Setup.exe

Note: See TracTickets for help on using tickets.