Opened 8 years ago

Closed 8 years ago

#1519 closed defect (fixed)

Opening a saved workspace doesn't display all layers correctly in 6.4.2RC2

Reported by: shanel Owned by: grass-dev@…
Priority: minor Milestone: 6.4.2
Component: wxGUI Version: 6.4.2 RCs
Keywords: workspace Cc:
CPU: x86-64 Platform: Linux

Description

Hi all, have just compiled/installed 6.4.2RC2 on Ubuntu 10.04. Seemed to go OK. A glitch I noted on user list (but didn't report a bug for) in ~RC1 still seems to be there in wxpython gui. When I open a saved workspace with e.g. a background raster layer, and two vector (boundary/centroid/area) layers: whilst loading in the map display, the vectors are visible, when the (larger filesize) raster completes loading, it is the only layer visible despite the two vectors being listed as 'above' it and 'visible' in the manager GUI. If I uncheck/re-check just one of the vector layers in the manager, it refreshed the map display and all the layers then seem to display as expected. If any more detail required on system specs just ask :-)

Attachments (1)

opening-workspace-output (19.3 KB) - added by shanel 8 years ago.
terminal output on debug=5 for loading saved workspace

Download all attachments as: .zip

Change History (8)

comment:1 Changed 8 years ago by shanel

I found that if I have multiple displays in a saved GRASS workspace, then upon opening, the earlier displays will end up displaying correctly, through to the last display which will be the only one exhibiting this error.

Changed 8 years ago by shanel

Attachment: opening-workspace-output added

terminal output on debug=5 for loading saved workspace

comment:2 Changed 8 years ago by shanel

Have just tried in svn version 50505 on 28 Jan 2012; still find bug. Repeated it using North Carolina dataset by following steps:

  1. open GRASS in NC/Permanent
  2. add raster > soilsID
  3. add vector > busroute1
  4. add vector > zipcodes_wake

#optionally adjust line/fill colours e.g. for zipcodes, don't display area so raster is visible

  1. save this as a workspace
  2. close GRASS/workspace, open it from the saved file

    it seems to show busroute, then zipcode bdy and soils flash up, then display finishes with only soilsID raster visible.

  3. uncheck top item in Display manager i.e. zipcodes vector

    display then refreshes and shows busroute vector over soils raster.

  4. checking zipcodes again displays all three layers.

output from terminal when I open the saved workspace (debug=5 output) attached as a file for reference.

comment:3 in reply to:  2 Changed 8 years ago by shanel

apologies for cluttered format, used keyboard 'enter' for new lines, think I should have used the 'enter' tool that goes with the comments box... :-/

comment:4 Changed 8 years ago by annakrat

Keywords: workspace added

The problem is in wxgui.py in LoadWorkspaceFile?():

        if maptree:
            # reverse list of map layers
            maptree.Map.ReverseListOfLayers()

I removed this code in r50511 and it seems to be ok then. Backported to 6.5 and 7 too.

Anna

comment:5 in reply to:  4 Changed 8 years ago by shanel

Resolution: worksforme
Status: newclosed

Hi Anna,

I have just updated svn (50521?) and opened a saved workspace, it seems to work :-) No other major side-effects noticed but have not given GRASS an intensive workout yet today.

I have changed the status to resolved-worksforme I hope that's not being too ambitious in playing with its status? Will leave it for others with better knowledge to change its status any further.

Thanks for figuring it out :-)

-shane.

Replying to annakrat:

The problem is in wxgui.py in LoadWorkspaceFile?():

        if maptree:
            # reverse list of map layers
            maptree.Map.ReverseListOfLayers()

I removed this code in r50511 and it seems to be ok then. Backported to 6.5 and 7 too.

Anna

comment:6 Changed 8 years ago by neteler

Resolution: worksforme
Status: closedreopened

(Just updating to fixed, not worksforme)

comment:7 Changed 8 years ago by neteler

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.