Opened 11 years ago

Closed 11 years ago

#1478 closed defect (worksforme)

Too many files in destination directory v.out.ogr, write fails

Reported by: MarjanM444 Owned by: grass-dev@…
Priority: normal Milestone:
Component: Vector Version: 6.4.1
Keywords: Export, vector, write Cc:
CPU: x86-64 Platform: All

Description

If there are more than 1024(350?) files in destination directory, the write is not successfull. THis was proven to be problem on Linux as MS Windows platform. The problem is present for long time, please either document the behaviour or present a workaround.

Change History (4)

comment:1 by neteler, 11 years ago

What command failed (exact command line please)?

What is the file system you are using?

comment:2 by MarjanM444, 11 years ago

v.out.ogr -p input=testvect type=area 'dsn=/home/user1' olayer=11 layer=1

Filesystem is ext4 on linux.

in reply to:  description ; comment:3 by glynn, 11 years ago

Replying to MarjanM444:

If there are more than 1024(350?) files in destination directory, the write is not successfull. THis was proven to be problem on Linux as MS Windows platform. The problem is present for long time, please either document the behaviour or present a workaround.

v.out.ogr just passes the dsn= argument to OGR_Dr_CreateDataSource(). If there's a problem, it's in OGR itself, so I can only suggest reporting this to the GDAL/OGR maintainers.

in reply to:  3 comment:4 by MarjanM444, 11 years ago

Resolution: worksforme
Status: newclosed

Replying to glynn:

Replying to MarjanM444:

If there are more than 1024(350?) files in destination directory, the write is not successfull. THis was proven to be problem on Linux as MS Windows platform. The problem is present for long time, please either document the behaviour or present a workaround.

v.out.ogr just passes the dsn= argument to OGR_Dr_CreateDataSource(). If there's a problem, it's in OGR itself, so I can only suggest reporting this to the GDAL/OGR maintainers.

Thank you for your fast response. Will forward the problem to GDAL/OGR as this bug is present for long time.

Note: See TracTickets for help on using tickets.