Opened 11 years ago

Closed 11 years ago

#1462 closed defect (invalid)

r.walk not working in Lambert Conformal Conic projection

Reported by: cmbarton Owned by: grass-dev@…
Priority: critical Milestone: 6.4.2
Component: Raster Version: svn-releasebranch64
Keywords: r.walk Cc: cgravelm@…
CPU: Unspecified Platform: Unspecified

Description

r.walk seems to be ignoring topography in a Lambert projection. r.cost works fine. I'm attaching screen shots of an SRTM DEM of central Europe, the results of r.walk on that DEM (with a friction map of 1), and r.cost run on a slope map of the DEM from the same start point as r.walk.

Attachments (3)

lambert_dem.jpg (52.1 KB ) - added by cmbarton 11 years ago.
1km SRTM DEM of central Europe
lambert_rwalk.jpg (19.7 KB ) - added by cmbarton 11 years ago.
r.walk output based on SRTM DEM
lambert_rcost.jpg (56.8 KB ) - added by cmbarton 11 years ago.
r.cost output of slope map created from SRTM DEM (same starting point as r.walk map)

Download all attachments as: .zip

Change History (7)

by cmbarton, 11 years ago

Attachment: lambert_dem.jpg added

1km SRTM DEM of central Europe

by cmbarton, 11 years ago

Attachment: lambert_rwalk.jpg added

r.walk output based on SRTM DEM

by cmbarton, 11 years ago

Attachment: lambert_rcost.jpg added

r.cost output of slope map created from SRTM DEM (same starting point as r.walk map)

comment:1 by neteler, 11 years ago

Please replace the attachment "lambert_dem.jpg" with a GeoTIFF containing the projection.

comment:2 by cmbarton, 11 years ago

Markus,

Turns out my map is in Lambert Equal Area. My student's map is in Lambert Conformal Conic and gives the same result. A geotif of the DEM is 3.9 MB, which far exceeds the 256 Kb limit of the bug tracker. However, the world file for r.out.tif is

999.420668933852198 
0.000000000000000 
0.000000000000000 
-1000.379912587064837 
4927643.608154466375709 
3452811.268273706547916 

...and g.proj gives the following:

g.proj -p                                                                       
-PROJ_INFO-------------------------------------------------
name       : Lambert Azimuthal Equal Area
proj       : laea
a          : 6378137
es         : 0.006694379990141282
lat_0      : 52
lon_0      : 10
x_0        : 4321000
y_0        : 3210000
towgs84    : 0,0,0,0,0,0,0
no_defs    : defined
-PROJ_UNITS------------------------------------------------
unit       : meters
units      : meterss
meters     : 1

I can post the DEM somewhere if you want

Michael

comment:3 by mmetz, 11 years ago

From the dev ml, Oct 11 2011, Claudine Gravel Miguel:

"I think I've found what I thought it wasn't working. I reran the whole thing on both UTM and conical and when looking at a big region, it seemed like it wasn't working, but as soon as I zoom the window on the 'center' point and I recalibrate the colors of the r-walk output, then the paths appear to be fine, on both locations. I also ran the whole thing in both 6.4.2 and 7 and both works fine. I wonder if the problem you had is the same, Michael, or if it was different.

I think that te reason why I thought the circle around the center point was wrong is because I was comparing it to r.walk in lat long, which was following very closely the results found in r.cost (following the valleys), which, I know realize, were the wrong type of outcome.

So, I guess my part of the problem is resolved. Thanks for your help!"

Close ticket?

Markus M

comment:4 by cmbarton, 11 years ago

Resolution: invalid
Status: newclosed

I have not personally tested, but Claudine did. It looks like we were having a similar issue to what you found. I supposed we should close this.

Michael

Note: See TracTickets for help on using tickets.