Opened 8 years ago

Closed 8 years ago

#1450 closed defect (fixed)

grass 6.4.svn nightly build fails on startup

Reported by: hamish Owned by: grass-dev@…
Priority: critical Milestone: 6.4.2
Component: wxGUI Version: svn-releasebranch64
Keywords: wingrass Cc:
CPU: x86-32 Platform: MSWindows XP

Description

Hi,

I just downloaded the latest nightly 6.4svn build r48286

the without msys icon doesn't launch grass, the with-msys gives this error in the terminal after you chose your mapset and click [continue] ..

Welcome to GRASS 6.4.2svn (2011) 
GRASS homepage:                          http://grass.osgeo.org/
This version running thru:               Bourne Shell (/bin/sh)
Help is available with the command:      g.manual -i
See the licence terms with:              g.version -c
If required, restart the GUI with:       g.gui wxpython
When ready to quit enter:                exit

GRASS 6.4> Traceback (most recent call last):
  File "c:/Program Files/GRASS 6.4.SVN/etc/wxpython/wxgui.py", line 65, in <modu                       le>
    from gui_modules import layertree
  File "c:\Program Files\GRASS 6.4.SVN\etc\wxpython\gui_modules\layertree.py", l                       ine 44, in <module>
    import toolbars
  File "c:/osgeo4w/usr/src/grass64_release/dist.i686-pc-mingw32/etc/wxpython/gui                       _modules/toolbars.py", line 44, in <module>
  File "c:/osgeo4w/usr/src/grass64_release/dist.i686-pc-mingw32/etc/wxpython/gui                       _modules/vdigit.py", line 43, in <module>
  File "c:\Program Files\GRASS 6.4.SVN\etc\wxpython\gui_modules\wxvdigit.py", li                       ne 25, in <module>
    from wxvdriver   import DisplayDriver
  File "c:\Program Files\GRASS 6.4.SVN\etc\wxpython\gui_modules\wxvdriver.py", l                       ine 28, in <module>
    from grass.lib.gis    import *
  File "c:\Program Files\GRASS 6.4.SVN\etc\python\grass\lib\__init__.py", line 4                       , in <module>
    import proj
  File "c:\Program Files\GRASS 6.4.SVN\etc\python\grass\lib\proj.py", line 23, i                       n <module>
    _libs["grass_gproj.6.4.2svn"] = load_library("grass_gproj.6.4.2svn")
  File "c:\Program Files\GRASS 6.4.SVN\etc\python\grass\lib\ctypes_loader.py", l                       ine 55, in load_library
    return self.load(path)
  File "c:\Program Files\GRASS 6.4.SVN\etc\python\grass\lib\ctypes_loader.py", l                       ine 221, in load
    return _WindowsLibrary(path)
  File "c:\Program Files\GRASS 6.4.SVN\etc\python\grass\lib\ctypes_loader.py", l                       ine 207, in __init__
    self.cdll = ctypes.cdll.LoadLibrary(path)
  File "C:\Program Files\GRASS 6.4.SVN\Python25\lib\ctypes\__init__.py", line 43                       1, in LoadLibrary
    return self._dlltype(name)
  File "C:\Program Files\GRASS 6.4.SVN\Python25\lib\ctypes\__init__.py", line 34                       8, in __init__
    self._handle = _dlopen(self._name, mode)
WindowsError: [Error 14001] This application has failed to start because the app                       lication configuration is incorrect. Reinstalling the application may fix this p                       roblem
GRASS 6.4> g.version.exe 
GRASS 6.4.2svn48286 (2011) 
GRASS 6.4> 

?

thanks, Hamish

Change History (11)

comment:1 Changed 8 years ago by martinl

Keywords: wingrass added

comment:2 Changed 8 years ago by martinl

Priority: normalblocker

comment:3 in reply to:  description ; Changed 8 years ago by hellik

Replying to hamish:

Hi,

I just downloaded the latest nightly 6.4svn build r48286

the without msys icon doesn't launch grass, the with-msys gives this error in the terminal after you chose your mapset and click [continue] ..

tested with WinGRASS-6.4.SVN-r48305-1-Setup.exe on a german WinVista32-box

I can't reproduce this error.

starting wingrass with/without msys are starting normally here.

Helmut

comment:4 in reply to:  3 Changed 8 years ago by hellik

Replying to hellik:

Replying to hamish:

Hi,

I just downloaded the latest nightly 6.4svn build r48286

the without msys icon doesn't launch grass, the with-msys gives this error in the terminal after you chose your mapset and click [continue] ..

tested with WinGRASS-6.4.SVN-r48305-1-Setup.exe on a german WinVista32-box

I can't reproduce this error.

starting wingrass with/without msys are starting normally here.

and also tested here with WinGRASS-6.4.SVN-r48286-1-Setup.exe, but I'm even not able to reproduce the error here on my german winvista32-box.

Helmut

comment:5 Changed 8 years ago by hamish

I'll try to hunt down another (real) Windows XP machine to install it on -- the above failure happened on an otherwise-healthy freshly installed XP virtual machine.

here is someone else having "error 14001" with ctypes, the discussion seems rather relevant:

http://www.velocityreviews.com/forums/t711804-ctypes-error.html

there are a lot of hits for it, here's another:

http://stackoverflow.com/questions/2852652/how-to-fix-this-dll-loading-python-error

since this is a relatively fresh install of the OS I suspect it is the classic missing MS visual C++ runtime dll as hinted in the above urls. but the usual ver7 one or the ver9 which Martin has been fighting with on osgeo4w? Since the addition of ctypes do we now need both??

anyway it seems the bundled ctypes/python is dynamically linking instead of statically against the dll, so how do other GPL apps deal with this problem (cleanly)?

Hamish

comment:6 Changed 8 years ago by hamish

how to test for the missing msvcr71.dll (or ver9) either on:

  • install and suggest the download page for it? does the license allow the installer to offer to download it, like we do for the sample datasets?

or,

  • at grass startup so there's a more helpful error message?

(see also #1394)

Hamish

comment:7 Changed 8 years ago by hamish

installing msvcr71.dll didn't help. I didn't try msvcp71.dll as well, although a colleague using Windows7 needed both those (in that case it asked for them by name).

In order to fix the WindowsError: [Error 14001] This application has failed to start error I was getting on a fresh Windows XP machine I needed to install the Microsoft .NET Frameworks 3.1 followed by 3.5.

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=25 http://www.microsoft.com/download/en/details.aspx?id=21

perhaps the .NET Frameworks version 4 download helps too, but does not require the earlier versions to be installed first? (not tested)

suggested solution is to add some text to the wingrass README.html troubleshooting section.

Hamish

comment:8 Changed 8 years ago by martinl

I also cannot reproduce this error, maybe related to http://lists.osgeo.org/pipermail/grass-dev/2011-September/055703.html? Could you try more recent version?

comment:9 in reply to:  8 Changed 8 years ago by martinl

Replying to martinl:

I also cannot reproduce this error, maybe related to http://lists.osgeo.org/pipermail/grass-dev/2011-September/055703.html? Could you try more recent version?

this ticket is marked as blocker...

comment:10 Changed 8 years ago by martinl

Priority: blockercritical

There is no answer in last 7 weeks, downgrading the priority...

comment:11 Changed 8 years ago by hamish

Resolution: fixed
Status: newclosed

Hi,

re-tested with recent nightly 6.4 WinGRASS build (r49173) on a freshly installed Windows XP. Problem with GUI startup still exists.

Solution as noted in comment:7 is to install MS's Windows Installer 3.1 Redistributable (v2), followed by the .net v3.5 Framework.

Suggested remedy for this is to note + provide links for the necessary DLL installers for those that need them in the wingrass README.html notes?

-> added to the wiki page which is linked from README.html:

http://grass.osgeo.org/wiki/WinGRASS_Current_Status#XP.2F2000

Hamish

Note: See TracTickets for help on using tickets.