Opened 12 years ago

Closed 11 years ago

#145 closed defect (fixed)

wxgrass: Error in applying display overlay properties to rasters in Layer Manager

Reported by: epatton Owned by: grass-dev@…
Priority: minor Milestone: 6.4.0
Component: wxGUI Version: svn-trunk
Keywords: display, overlay, raster Cc:
CPU: Unspecified Platform: Unspecified

Description

This error comes and goes, and it's really hard to pin it down, unfortunately. I get the error when editing the properties of a raster by checking or unchecking the 'Overlay (non-null values only)' checkbox in d.rast properties for any raster in the Layer Manager:

Traceback (most recent call last):
  File "/usr/local/grass-6.4.svn/etc/wxpython/gui_modules/me
nuform.py", line 716, in OnOK

cmd = self.OnApply(event)
  File "/usr/local/grass-6.4.svn/etc/wxpython/gui_modules/me
nuform.py", line 728, in OnApply

self)
  File "/usr/local/grass-6.4.svn/etc/wxpython/gui_modules/wx
gui_utils.py", line 1032, in GetOptData

self.ChangeLayer(layer)
  File "/usr/local/grass-6.4.svn/etc/wxpython/gui_modules/wx
gui_utils.py", line 1086, in ChangeLayer

l_active=chk, l_hidden=hidden, l_opacity=opac,
l_render=False)
  File "/usr/local/grass-6.4.svn/etc/wxpython/gui_modules/re
nder.py", line 903, in ChangeLayer

oldlayerindex = self.layers.index(layer)
ValueError
:
list.index(x): x not in list

I will continue testing and post any additional information I can find about it.

~ Eric.

Change History (3)

comment:1 Changed 11 years ago by martinl

Component: PythonwxGUI

comment:2 Changed 11 years ago by cmbarton

CPU: Unspecified
Platform: Unspecified

Is this still a problem? i cannot reproduce.

comment:3 Changed 11 years ago by martinl

Resolution: fixed
Status: newclosed

After recent changes in wxGUI, it should be fixed (please reopen if not). Martin

Note: See TracTickets for help on using tickets.