Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#1448 closed defect (fixed)

run model menu item does not seem to work

Reported by: cmbarton Owned by: martinl
Priority: critical Milestone: 6.4.2
Component: wxGUI Version: svn-trunk
Keywords: modeler Cc: grass-dev@…
CPU: Unspecified Platform: Unspecified

Description

I made and saved a model using the graphical modeler. The model works fine. I can load the saved model into the graphical modeler and it works fine.

If I select "run model" from the file menu and select this saved model, nothing happens. No error and nothing produced.

Change History (12)

comment:1 by cmbarton, 11 years ago

Component: DefaultwxGUI

comment:2 by martinl, 11 years ago

Cc: grass-dev@… added
Keywords: modeler added
Owner: changed from grass-dev@… to martinl
Status: newassigned

comment:3 by martinl, 11 years ago

There is an error (check 'command output' if you have no debug level defined).

  File "/usr/local/src/grass64_release/dist.i686-pc-linux-gnu/etc/wxpython/gui_modules/gmodeler.py", line 1751, in _setPen
    pen = self.GetPen()
  File "/usr/lib/python2.6/dist-packages/wx-2.8-gtk2-unicode/wx/lib/ogl/_basic.py", line 2069, in GetPen
    return self._pen
AttributeError: 'ModelAction' object has no attribute '_pen'

Hopefully fixed in r48307 (trunk) and r48308 (devbr6). After some testing it could be backported to relbr64.

comment:4 by cmbarton, 11 years ago

Tested in trunk. Now it runs without an error. But it does not respect the 'parameterization' checkbox when run this way. That is, it does not open a dialog for file selection or module options when the relevant parameterization box is checked. When loaded and run in the modeler GUI window, it does present dialogs for parameterized options. I don't know if this is by design or not.

Michael

in reply to:  4 comment:5 by martinl, 11 years ago

Replying to cmbarton:

Tested in trunk. Now it runs without an error. But it does not respect the 'parameterization' checkbox when run this way. That is, it does not open a dialog for file selection or module options when the relevant parameterization box is checked. When loaded and run in the modeler GUI window, it does present dialogs for parameterized options. I don't know if this is by design or not.

hopefully fixed in r48342 (trunk) and r48343 (develbr6).

comment:6 by martinl, 11 years ago

Priority: normalcritical

in reply to:  6 comment:7 by martinl, 11 years ago

Replying to martinl:

Candidates for backport (relbr64):

comment:8 by cmbarton, 11 years ago

I just tested. Parameterization is now respected in the run model. AFAICT it works fine. Thanks much!

Michael

in reply to:  8 comment:9 by martinl, 11 years ago

Replying to cmbarton:

I just tested. Parameterization is now respected in the run model. AFAICT it works fine. Thanks much!

Backported to relr64 in r48387. Before closing this ticket, could you test also G64? Thanks.

comment:10 by cmbarton, 11 years ago

Resolution: fixed
Status: assignedclosed

Tested and it seems to work fine. I ran into an error initially that I traced to the fact that the output argument for r.blend has changed in GRASS 7 from "output" to "output_prefix" . A more accurate name for the argument but it breaks backward compatibility (permitted across version changes of course).

Thanks again for making this very nice tool for GRASS. I've already been recommending it as a way to get started writing Python scripts. I'll go ahead and close this.

BTW, how does the variables section work for the modeler?

Michael

in reply to:  10 comment:11 by martinl, 11 years ago

Replying to cmbarton:

BTW, how does the variables section work for the modeler?

http://www.youtube.com/watch?v=RztxMXXtA0s&feature=player_embedded#!

comment:12 by cmbarton, 11 years ago

Very cool!

Thanks.

Michael

Note: See TracTickets for help on using tickets.