Opened 8 years ago

Closed 3 years ago

#1442 closed defect (fixed)

GRASS 7: d.grid layout suboptimal

Reported by: neteler Owned by: hamish
Priority: normal Milestone: 7.0.5
Component: Display Version: svn-trunk
Keywords: d.grid Cc: grass-dev@…
CPU: x86-64 Platform: Linux

Description (last modified by neteler)

d.grid latitudes are poorly drawn, seen screenshot.

# in latlong
g.region n=90 s=-90 w=-180 e=180
d.mon wx0
d.grid 10

Attachments (1)

bug_grass7_worldgrid10deg.png (182.3 KB) - added by neteler 8 years ago.
d.grid text label problems

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by neteler

d.grid text label problems

comment:1 Changed 8 years ago by neteler

Description: modified (diff)

comment:2 Changed 6 years ago by hamish

Cc: grass-dev@… added
Keywords: d.grid added
Owner: changed from grass-dev@… to hamish
Status: newassigned

comment:3 Changed 6 years ago by hamish

Hi,

is this still the case since the last round of d.grid text placement bug fixes?

Hamish

comment:4 in reply to:  3 Changed 6 years ago by neteler

Replying to hamish:

is this still the case since the last round of d.grid text placement bug fixes?

Yes, looks as before.

comment:5 Changed 6 years ago by hamish

ok, as per ticket subject this is only an issue in trunk, in 6.x all is ok.

Hamish

comment:6 Changed 6 years ago by hamish

mostly fixed in trunk with r57714.

remaining issues:

  • there's some code in plot.c and plotborder.c to pull back the east and southern borders by 1 display pixel, but it's not working right, sometimes (~50%) they are off the edge of the window. I presume it's another +0.5 pixel thing and had a try at fixing it, but no luck. (grid lines too, but if present the border hides those sins)
  • geogrid (-g) lines are not clipped to frame (at least with the lines of longitude crossing the western and northern region border). How to make D_line_abs() clipped by the region box? (plot.c line 288)

also it would be nice if latitude and northing text which would cross or exceed the region frame would be clipped to it, or not rendered at all.

Hamish

comment:7 Changed 3 years ago by martinl

Milestone: 7.0.07.0.5

comment:8 Changed 3 years ago by martinl

The last comment is 3 years old. What is the status of this ticket? Probably something what could be done within GSoC 2016?

comment:9 Changed 3 years ago by annakrat

Resolution: fixed
Status: assignedclosed

The main problem was fixed 3 years ago, I don't know how to reproduce the other things. Create a new ticket if necessary.

Note: See TracTickets for help on using tickets.