Opened 14 years ago

Closed 14 years ago

#143 closed defect (fixed)

WinGRASS Installer fails retrieving the user name on some XP versions

Reported by: timmie Owned by: 4everskiff
Priority: major Milestone: 6.3.1
Component: Default Version: 6.3.0
Keywords: Cc: marco.pasetti@…
CPU: Unspecified Platform: Unspecified

Description

On [New GRASS Python GUI - http://grass.itc.it/grass63/binary/mswindows/native/#New%20GRASS%20Python%20GUI] it says that I need just to type grass63 -wxpython in a Mingw32Shell. When I doo this the shell reports "sh: grass63: command not found".

I suppose that a shell script for starting Grass is missing.

Using Windowws XP and the installer with RC6

Attachments (1)

WinGRASS-Bug143-Patch.exe (71.9 KB) - added by 4everskiff 14 years ago.
WinGRASS-Bug143-Patch.exe

Download all attachments as: .zip

Change History (14)

comment:1 in reply to:  description Changed 14 years ago by 4everskiff

Cc: marco.pasetti@… added

Replying to timmie:

On [New GRASS Python GUI - http://grass.itc.it/grass63/binary/mswindows/native/#New%20GRASS%20Python%20GUI] it says that I need just to type grass63 -wxpython in a Mingw32Shell. When I doo this the shell reports "sh: grass63: command not found".

I suppose that a shell script for starting Grass is missing.

Using Windowws XP and the installer with RC6

Please, try it with the current WinGRASS release (6.3.0). Thanks

Marco

comment:2 Changed 14 years ago by 4everskiff

Owner: changed from grass-dev@… to 4everskiff

comment:3 Changed 14 years ago by 4everskiff

Status: newassigned

comment:4 in reply to:  description Changed 14 years ago by 4everskiff

Resolution: invalid
Status: assignedclosed

Replying to timmie:

On [New GRASS Python GUI - http://grass.itc.it/grass63/binary/mswindows/native/#New%20GRASS%20Python%20GUI] it says that I need just to type grass63 -wxpython in a Mingw32Shell. When I doo this the shell reports "sh: grass63: command not found".

I suppose that a shell script for starting Grass is missing.

Using Windowws XP and the installer with RC6

I check it out on another XP machine, and it works fine with current GRASS release (WinGRASS 6.3.0). Invalid bug. Ticket closed.

Marco

comment:5 Changed 14 years ago by timmie

Resolution: invalid
Status: closedreopened

This is still not working here. I did a new install of 6.3.0 when logged in as Administrator.

Reproduce: 1) open Mingw32 Shell from start menu 2) type grass63 => result sh: grass63: command not found 3) type grass63 -wxpython => same result as in 2)

note that the 6.3.0 installer did also not set up the sample location.

comment:6 in reply to:  5 Changed 14 years ago by 4everskiff

Milestone: 6.3.06.3.1
Version: 6.3.0 RCs6.3.0

Replying to timmie:

This is still not working here. I did a new install of 6.3.0 when logged in as Administrator.

Reproduce: 1) open Mingw32 Shell from start menu 2) type grass63 => result sh: grass63: command not found 3) type grass63 -wxpython => same result as in 2)

note that the 6.3.0 installer did also not set up the sample location.

Could you give me please some information about your system configuration? such as your %userprofile% variable?

Marco

comment:7 Changed 14 years ago by timmie

M:\>echo %userprofile% C:\Dokumente und Einstellungen\timmie

I am using XP. German version.

python is installed to c:\python and is included in %Path%

Please tell me if you'd need more information.

comment:8 in reply to:  7 Changed 14 years ago by 4everskiff

Summary: not possible to start -wxpython on windowsWinGRASS Installer fails retrieving the user name on some XP versions

Replying to timmie:

M:\>echo %userprofile% C:\Dokumente und Einstellungen\timmie

I am using XP. German version.

python is installed to c:\python and is included in %Path%

Please tell me if you'd need more information.

Hi Timmie,

I've got the problem.

I must use a walkaround in the installer script, because the script engine is not able to retrive the name of the account in use during install procedure; since that, the installer script defines the user name from its %userprofile% variable, simply removing the "Documents and Settings\" from it... but I thought that every version of XP had "Documents and Settings\" as *user profiles root* (as my italian XP version has, though).... but it is not!!

This said, if the installer script cannot create the correct %username% folder in "..\GRASS\msys\home\", at the same time it cannot create the grass63 file (needed to launch GRASS from the msys shell).

I must work on it, finding how to retrieve the user name variable with NSIS. I'll do it from the next GRASS release. If you tell me where did you installed GRASS I'll send you the correct grass63 file to let you launch GRASS from msys shell.

Marco

PS: did you subscribed the grass-dev mailing list?

comment:9 in reply to:  7 Changed 14 years ago by 4everskiff

Hi Timmie,

please, try the patch attached. Let me know if it works.

Marco

Changed 14 years ago by 4everskiff

Attachment: WinGRASS-Bug143-Patch.exe added

WinGRASS-Bug143-Patch.exe

comment:10 Changed 14 years ago by timmie

Hi, the patch worked well. Even applying it from the normal user account it works.

P.S: The new GUI is great!

comment:11 in reply to:  10 Changed 14 years ago by 4everskiff

Status: reopenednew

Replying to timmie:

Hi, the patch worked well. Even applying it from the normal user account it works.

P.S: The new GUI is great!

Good. I'll modify the installer script for the next release. (or should I reupload the installer modified since now?)

Markus?

comment:12 Changed 14 years ago by 4everskiff

Status: newassigned

comment:13 in reply to:  10 Changed 14 years ago by 4everskiff

Resolution: fixed
Status: assignedclosed

Replying to timmie:

Hi, the patch worked well. Even applying it from the normal user account it works.

P.S: The new GUI is great!

OK. I uploaded the new installer (fixed) and updated the installer script in the SVN win32 folder.

Marco

Note: See TracTickets for help on using tickets.