Opened 11 years ago

Closed 10 years ago

#1417 closed defect (fixed)

Error during Grass start

Reported by: RazorCharlie Owned by: grass-dev@…
Priority: normal Milestone:
Component: Startup Version: 6.4.1 RCs
Keywords: g.region, wingrass, SSLEAY32.dll Cc:
CPU: x86-32 Platform: MSWindows XP

Description (last modified by martinl)

Just after GRASS installatin during Grass start I got a problem.

I can't start Grass having error message: Unable to get current geografic extent. Force quiting wxGUI.

Attachments (7)

Error_duringGrassStart.jpg (130.3 KB ) - added by RazorCharlie 11 years ago.
Error message
Error_duringGrassStart2.jpg (214.4 KB ) - added by RazorCharlie 11 years ago.
ErrorMessage.txt (2.1 KB ) - added by RazorCharlie 11 years ago.
Error_duringGrassStart30.jpg (104.3 KB ) - added by RazorCharlie 11 years ago.
Welcome window with customization screen. All data directories are correct
Error_duringGrassStart31.jpg (153.1 KB ) - added by RazorCharlie 11 years ago.
Error_duringGrassStart32.jpg (94.0 KB ) - added by RazorCharlie 11 years ago.
Error_duringGrassStart33.jpg (115.0 KB ) - added by RazorCharlie 11 years ago.

Download all attachments as: .zip

Change History (17)

by RazorCharlie, 11 years ago

Attachment: Error_duringGrassStart.jpg added

Error message

comment:1 by martinl, 11 years ago

Keywords: g.region added

Start GRASS in the text mode and run

g.region -p

from command line to get more relevant info.

comment:2 by martinl, 11 years ago

Description: modified (diff)

by RazorCharlie, 11 years ago

Attachment: Error_duringGrassStart2.jpg added

by RazorCharlie, 11 years ago

Attachment: ErrorMessage.txt added

in reply to:  2 ; comment:3 by RazorCharlie, 11 years ago

Replying to martinl: g.region -p command did not solve the problem. It persists. -Alexander

in reply to:  3 comment:4 by hellik, 11 years ago

Replying to RazorCharlie:

Replying to martinl: g.region -p command did not solve the problem. It persists. -Alexander

but the output of g.region -p would be necessary to get more relevant info about the current region.

best regards Helmut

in reply to:  3 comment:5 by martinl, 11 years ago

Replying to RazorCharlie:

Replying to martinl: g.region -p command did not solve the problem. It persists.

I didn't said that it will solve problem. At least it can tell where the problem is? So what does this command say?

by RazorCharlie, 11 years ago

Welcome window with customization screen. All data directories are correct

by RazorCharlie, 11 years ago

by RazorCharlie, 11 years ago

by RazorCharlie, 11 years ago

comment:6 by RazorCharlie, 11 years ago

g.region -p says:

"The ordinal 284 coul not be located in the dynamic link library SSLEAY32.dll", see attached files

in reply to:  6 comment:7 by martinl, 11 years ago

Replying to RazorCharlie:

g.region -p says:

"The ordinal 284 coul not be located in the dynamic link library SSLEAY32.dll", see attached files

See http://lists.osgeo.org/pipermail/grass-user/2011-June/061081.html

in reply to:  6 ; comment:8 by hellik, 11 years ago

Replying to RazorCharlie:

g.region -p says:

"The ordinal 284 coul not be located in the dynamic link library SSLEAY32.dll", see attached files

please try one of the latest nightly builds of wingrass64svn http://wingrass.fsv.cvut.cz/grass64/

best regards Helmut

in reply to:  8 comment:9 by razorcharlie, 11 years ago

Replying to hellik:

Replying to RazorCharlie:

g.region -p says:

"The ordinal 284 coul not be located in the dynamic link library SSLEAY32.dll", see attached files

please try one of the latest nightly builds of wingrass64svn http://wingrass.fsv.cvut.cz/grass64/

best regards Helmut

Just before your answer I have installed QGIS (QGIS-OSGeo4W-1.7.0-b55a00e73-Setup.exe) from http://www.qgis.org/. During it's installation additional Visual C++ libraries were installed. Strange but it solved the problem with GRASS start!

I haven't tried new builds yet because it seems that all works as it should do. Thank you for your assistance!

Regards, Alexander

comment:10 by hamish, 10 years ago

Component: DefaultStartup
Keywords: wingrass SSLEAY32.dll added
Resolution: fixed
Status: newclosed

fwiw, on a new install of the 6.4.2rc3 stand-alone package I needed to download and install msvcp71.dll before it would run. (earlier version of the same didn't need that)

Note: See TracTickets for help on using tickets.