Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1412 closed defect (invalid)

Different problem with scalebar in GRASS 6.5

Reported by: cmbarton Owned by: grass-dev@…
Priority: major Milestone: 6.5.0
Component: wxGUI Version: svn-develbranch6
Keywords: barscale Cc:
CPU: Unspecified Platform: Unspecified

Description

The north arrow in GRASS 6.5 looks OK and is not multiple (as I just reported as a problem in GRASS 7 (trac #1410).

BUT, once you've added a scale bar or north arrow, you cannot change it. Neither double clicking or nor trying to access the dialog called from the toolbar will access it. These both generate the following error:

Traceback (most recent call last):
  File "/Users/Shared/grass_dev/grass65_dev/dist.i386-apple-
darwin10.8.0/etc/wxpython/gui_modules/mapdisp_window.py",
line 1025, in MouseActions

self.OnButtonDClick(event)
  File "/Users/Shared/grass_dev/grass65_dev/dist.i386-apple-
darwin10.8.0/etc/wxpython/gui_modules/mapdisp_window.py",
line 1300, in OnButtonDClick

self.parent.OnAddBarscale(None)
  File "/Users/Shared/grass_dev/grass65_dev/dist.i386-apple-
darwin10.8.0/etc/wxpython/gui_modules/mapdisp.py", line
1761, in OnAddBarscale

ctrltxt = _("scale object"))
  File "/Users/Shared/grass_dev/grass65_dev/dist.i386-apple-
darwin10.8.0/etc/wxpython/gui_modules/gdialogs.py", line
496, in __init__

mapName, found = utils.GetLayerNameFromCmd(self.parent.MapWi
ndow.overlays[self.ovlId]['cmd'])
  File "/Users/Shared/grass_dev/grass65_dev/dist.i386-apple-
darwin10.8.0/etc/wxpython/gui_modules/utils.py", line 160,
in GetLayerNameFromCmd

maps.append(dcmd[i].split('=', 1)[1])
IndexError
:
list index out of range

Michael

Change History (9)

comment:1 Changed 8 years ago by martinl

Are you using fresh compilation from SVN? I am not able to reproduce this behaviour with G65.

comment:2 Changed 8 years ago by martinl

Keywords: barscale added

comment:3 Changed 8 years ago by cmbarton

Just compiled an hour ago r47252

Michael

comment:4 Changed 8 years ago by cmbarton

The scale bar in the GUI works fine in 6.4.2svn r47214.

comment:5 Changed 8 years ago by cmbarton

Resolution: invalid
Status: newclosed

I rebooted my machine, restarted GRASS, and this error does not seem to be happening any more. (the others reported yesterday still do, and do so on my desktop too). I will close since Martin cannot reproduce and it has magically disappeared from my box too.

Michael

comment:6 Changed 8 years ago by annakrat

It's weird, I still get this error and I tried to fix it (5 min ago, I didn't noticed you closed it). The problem appears when the option north arrow only is checked. I have just commited the patch in G7 (the same error as G65). Please try it.

Anna

comment:7 Changed 8 years ago by cmbarton

Did you find out why G7 is displaying 3 N. arrows in a horizontal row, with no fill on one of them?

Michael

comment:8 in reply to:  7 Changed 8 years ago by annakrat

Replying to cmbarton:

Did you find out why G7 is displaying 3 N. arrows in a horizontal row, with no fill on one of them?

No, but I guess it's problem with d.barscale and not wxGUI.

Anna

comment:9 Changed 8 years ago by cmbarton

It seems to be only a problem with latlon locations. I just tested the other issue (not keeping settings and raising an error), and it seems like you've fixed it.

So it seems like there were 2 different issues in 2 different GRASS systems. You've fixed the wxGUI one, but the other one remains and is likely to be in d.barscale. So I will indicate this for trac #1410. We can keep this closed this I believe.

Note: See TracTickets for help on using tickets.