Opened 12 years ago

Closed 11 years ago

#1384 closed defect (fixed)

wxGUI Preferences: apply or save settings erases Layer Manager menu

Reported by: mmetz Owned by: martinl
Priority: major Milestone: 6.4.2
Component: wxGUI Version: svn-releasebranch64
Keywords: wxGUI, Preferences Cc: grass-dev@…
CPU: All Platform: All

Description

In the wxGUI Preferences dialog, when clicking on Apply or on Save, the menu bar "File Settings Raster .." is erased to blank. Cancel works.

Maybe related: in gui/wxpython/gui_modules/preferences.py, the function _updateSettings of class PreferencesDialog is never called, and the current window layout never saved. The function _updateSettings of class PreferencesBaseDialog does not check the current window layout.

Attachments (1)

erased_menubar.png (16.5 KB ) - added by mmetz 12 years ago.
screenshot of erased menubar

Download all attachments as: .zip

Change History (7)

comment:1 by martinl, 12 years ago

Cc: martinl added

Unable to reproduce this bug? What version of wxPython? Could you send a screenshot?

in reply to:  description ; comment:2 by wenzeslaus, 12 years ago

I also cannot reproduce it (grass 7, Ubuntu 10.04, wxPython 2.8.10.1 (gtk2-unicode)). But I think that problem is caused by new code writen by me (change menu style). Menu bar is re-created always after "Apply" or "Save".

The possible solution is do not change menu style (do not re-create menu) on the fly but only after GUI restart (same as "icon theme").

in reply to:  2 ; comment:3 by martinl, 12 years ago

Replying to wenzeslaus:

I also cannot reproduce it (grass 7, Ubuntu 10.04, wxPython 2.8.10.1 (gtk2-unicode)). But I think that problem is caused by new code writen by me (change menu style). Menu bar is re-created always after "Apply" or "Save".

it can be, see r46397

by mmetz, 12 years ago

Attachment: erased_menubar.png added

screenshot of erased menubar

comment:4 by mmetz, 12 years ago

Priority: blockermajor

I have a screenshot attached. My wxPython version is 2.8.12, recently upgraded from 2.8.11, and I can not remember having seen this before. Maybe this is the problem, because wxPython often comes with interesting changes between 2.8.x versions. Or my Fedora version of wxPython is patched to death...

Downgrading priority.

in reply to:  3 comment:5 by martinl, 11 years ago

Cc: grass-dev@… added; martinl removed
Owner: changed from grass-dev@… to martinl
Status: newassigned

Replying to martinl:

Replying to wenzeslaus:

I also cannot reproduce it (grass 7, Ubuntu 10.04, wxPython 2.8.10.1 (gtk2-unicode)). But I think that problem is caused by new code writen by me (change menu style). Menu bar is re-created always after "Apply" or "Save".

it can be, see r46397

patch provided by Vaclav applied in r46665 (& backported to devbr6/relbr64).

comment:6 by martinl, 11 years ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.