Opened 12 years ago

Closed 11 years ago

#1355 closed defect (fixed)

Error starting wxpython v.digit session

Reported by: epatton Owned by: martinl
Priority: normal Milestone: 6.4.2
Component: wxGUI Version: svn-develbranch6
Keywords: digitizer Cc: grass-dev@…
CPU: x86-32 Platform: Linux

Description (last modified by martinl)

This error is printed to the Layer Manager o utput window when I try to start editing an existing vector. I select "Digitize" from the drop-down box on the Map Display, and then select the name of my vector under the left-most drop-down box in the Map Display. The Map Display doesn't draw any of my GIS layers, but goes completely white at this point.

I have rebuilt the vector topology, but the error still occurs. I have tested the wxgui digitizer in a different mapset with a different vector, with the same error occurring.

~ Eric.

Attachments (1)

digitizing_error.txt (936 bytes ) - added by epatton 12 years ago.

Download all attachments as: .zip

Change History (11)

by epatton, 12 years ago

Attachment: digitizing_error.txt added

comment:1 by martinl, 12 years ago

Component: wxGUIPython ctypes
Keywords: G_gisinit() added; v.digit removed

It's ctypes bug in GRASS 6 (in GRASS 7 working).

>>> from grass.lib.gis import *
>>> G_gisinit('')
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/local/src/grass6_devel/dist.i686-pc-linux-gnu/etc/python/grass/lib/gis.py", line 6986, in G_gisinit
    return (G__gisinit (GIS_H_VERSION, pgm))
NameError: global name 'G__gisinit' is not defined

comment:2 by martinl, 12 years ago

Cc: grass-dev@… added
Description: modified (diff)
Milestone: 6.5.06.4.2
Owner: changed from grass-dev@… to martinl
Status: newassigned

Hopefully fixed in r46171.

BTW, vector digizer in 6.4.2+ needs some testing. The component has been recently ported from C++ to Python. It would be good to catch & fix major part of possible bugs before we release 6.4.2 as the first version with working wxGUI vector digitizer (including winGRASS).

Martin

in reply to:  2 comment:3 by martinl, 12 years ago

Replying to martinl:

Hopefully fixed in r46171.

Backported to relbr64 in r46172

comment:4 by epatton, 12 years ago

Thanks. I refreshed my source, recompiled, and tried editing with the WXGUI digitizer again, I get this error:

Traceback (most recent call last):
  File "/usr/local/grass-6.5.svn/etc/wxpython/gui_modules/to
olbars.py", line 1127, in OnSelectMap

self.StartEditing(self.layers[selection])
  File "/usr/local/grass-6.5.svn/etc/wxpython/gui_modules/to
olbars.py", line 1142, in StartEditing

self.parent.MapWindow.EraseMap()
  File "/usr/local/grass-6.5.svn/etc/wxpython/gui_modules/ma
pdisp_window.py", line 830, in EraseMap

self.Draw(self.pdcVector, pdctype = 'clear')
  File "/usr/local/grass-6.5.svn/etc/wxpython/gui_modules/ma
pdisp_window.py", line 293, in Draw

pdc.BeginDrawing()
AttributeError
:
'NoneType' object has no attribute 'BeginDrawing'
Traceback (most recent call last):
  File "/usr/local/grass-6.5.svn/etc/wxpython/gui_modules/ma
pdisp_window.py", line 472, in OnPaint

self.pdcVector.DrawToDCClipped(gcdc, rgn)
AttributeError
:
'NoneType' object has no attribute 'DrawToDCClipped'


~ Eric.

comment:5 by martinl, 12 years ago

Component: Python ctypeswxGUI
Keywords: digitizer added; G_gisinit() removed

in reply to:  4 comment:6 by martinl, 12 years ago

Replying to epatton:

Thanks. I refreshed my source, recompiled, and tried editing with the WXGUI digitizer again, I get this error:

I am unable to reproduce this error, could you describe in detail the process? Thanks.

comment:7 by epatton, 12 years ago

Using the NC simpler subset, add the boundary_region vector to the layer manager, choose 'Digitize' from the drop-down menu in the right-hand corner of the Map Display, choose 'boundary_region' from the left drop-down menu of the left-corner of the Map Display, then after the nodes and centroids become visible, try zooming or panning - nothing should happen. If I then try to erase and re-display the map window, I get the following error (which is different from the one posted yesterday - not sure why)

Traceback (most recent call last):
  File "/usr/local/grass-6.5.svn/etc/wxpython/gui_modules/ma
pdisp.py", line 571, in OnRender

self.MapWindow.display.SetSelected([])
AttributeError
:
'VDigitWindow' object has no attribute 'display'

~ Eric.

in reply to:  7 comment:8 by martinl, 11 years ago

Replying to epatton:

> Traceback (most recent call last):
>   File "/usr/local/grass-6.5.svn/etc/wxpython/gui_modules/ma
> pdisp.py", line 571, in OnRender
> 
> self.MapWindow.display.SetSelected([])
> AttributeError
> :
> 'VDigitWindow' object has no attribute 'display'

please try more recent version from SVN.

comment:9 by neteler, 11 years ago

yesterday GRASS 6.4.2RC1 has been released. Does this problem persist?

comment:10 by martinl, 11 years ago

Resolution: fixed
Status: assignedclosed

Should be fixed, please re-open if needed.

Note: See TracTickets for help on using tickets.