Opened 9 years ago

Closed 9 years ago

#1298 closed defect (fixed)

v.digit crashes dbf.exe on Windows when creating attribute table

Reported by: marisn Owned by: grass-dev@…
Priority: critical Milestone: 6.4.1
Component: Database Version: svn-releasebranch64
Keywords: wingrass, dbf Cc: martinl
CPU: Unspecified Platform: MSWindows Vista

Description

Steps to reproduce:

  • Start v.digit with -n flag
  • Go to settings -> Attribute table
  • Add a new attribute "foo" integer
  • Click "Create table"
  • Opens a new window. Wait... KaBOOM!
  • v.digit is unresponsive and has to be killed.

WinGRASS-6.4.SVN-r45559-1

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	dbf.exe
  Application Version:	0.0.0.0
  Application Timestamp:	4d71a393
  Fault Module Name:	ntdll.dll
  Fault Module Version:	6.0.6002.18327
  Fault Module Timestamp:	4cb73436
  Exception Code:	c0000005
  Exception Offset:	000673c0
  OS Version:	6.0.6002.2.2.0.256.6
  Locale ID:	1062
  Additional Information 1:	2cd9
  Additional Information 2:	0026203478d1c76ac67d137d9a30fc40
  Additional Information 3:	13dc
  Additional Information 4:	e9415589de4c91338c0e303bde9d82c3

Change History (5)

comment:1 Changed 9 years ago by neteler

The ntdll.dll crash was also reported in #537. No idea if related... It may be a [G_]free() problem. See also

http://osgeo-org.1803224.n2.nabble.com/gdb-debug-for-grass-g-proj-crash-in-Windows-Vista-td2511560.html

comment:2 Changed 9 years ago by martinl

Cc: martinl added
Component: Tcl/TkDatabase
Keywords: wingrass dbf added

I discovered that dbf.exe sometimes crashes in new winGRASS builds, e.g.

  • adding new vector to wxGUI
  • open attribute table

comment:3 in reply to:  2 ; Changed 9 years ago by hellik

Replying to martinl:

I discovered that dbf.exe sometimes crashes in new winGRASS builds, e.g.

  • adding new vector to wxGUI
  • open attribute table

see also #1308 (http://trac.osgeo.org/grass/ticket/1308)

comment:4 in reply to:  3 ; Changed 9 years ago by hellik

Replying to hellik:

Replying to martinl:

I discovered that dbf.exe sometimes crashes in new winGRASS builds, e.g.

  • adding new vector to wxGUI
  • open attribute table

see also #1308 (http://trac.osgeo.org/grass/ticket/1308)

with fixes for #1308, I can't reproduce this issue anymore. I would vote for closing the ticket.

Helmut

comment:5 in reply to:  4 Changed 9 years ago by martinl

Resolution: fixed
Status: newclosed

Replying to hellik:

with fixes for #1308, I can't reproduce this issue anymore. I would vote for closing the ticket.

closed, please reopen if needed.

Note: See TracTickets for help on using tickets.