Opened 9 years ago

Closed 6 years ago

#1275 closed defect (fixed)

zipped HGT Import fails on wingrass as "unzip" isn't in the package

Reported by: MartinOver Owned by: grass-dev@…
Priority: normal Milestone: 6.4.3
Component: Packaging Version: svn-releasebranch64
Keywords: r.in.srtm, wingrass, unzip Cc:
CPU: All Platform: MSWindows XP

Description

The import of srtm .hgt raster data is not working.

unzip: unknown command ERROR: The "unzip" program is required, please install it first

Change History (18)

comment:1 Changed 9 years ago by msieczka

Component: DefaultPackaging
CPU: x86-32All
Keywords: unzip missing on Win (r.in.srtm req) added; HGT Import removed

comment:2 Changed 9 years ago by hamish

Keywords: r.in.srtm wingrass added; unzip missing on Win (r.in.srtm req) removed

is this the standalone installer or installed by osgeo4w?

easy work around: unzip it yourself before running the program.

Hamish

comment:3 in reply to:  2 ; Changed 9 years ago by martinover

Replying to hamish:

is this the standalone installer or installed by osgeo4w?

easy work around: unzip it yourself before running the program.

Hamish

Hi Hamish,

It is in both the standalone and osgeo4w installation. The workaround does not work but I converted the hgt files via gdal_translate to GTiffs. The Problem is that I can import the Data in the standalone installation but can not export the dataset (empty image) or work with the dataset (for example wirth the raster calculator). In the osgeo4w installation I can´t even import the dataset. Is it possible for you to import and export the hgt files: http://dds.cr.usgs.gov/srtm/version2_1/SRTM3/Eurasia/

I tried both linux and windows systems.

Best regards,

Martin Over

comment:4 in reply to:  3 Changed 9 years ago by hamish

Replying to hamish:

easy work around: unzip it yourself before running the program.

Replying to martinover:

The workaround does not work

I am a bit surprised by that, it should.

The Problem is that I can import the Data in the standalone installation but can not export the dataset (empty image) or work with the dataset (for example wirth the raster calculator).

after import you need to change the working ("computational") region to match the bounds of the map. Run "g.region rast=your_map".

In the osgeo4w installation I can´t even import the dataset.

exact error messages are needed. (assuming it's not the same unzip one, which should only be shown if you feed it a .zip file)

Is it possible for you to import and export the hgt files: http://dds.cr.usgs.gov/srtm/version2_1/SRTM3/Eurasia/

(todo)

Hamish

comment:5 in reply to:  3 Changed 9 years ago by neteler

Replying to martinover:

Is it possible for you to import and export the hgt files: http://dds.cr.usgs.gov/srtm/version2_1/SRTM3/Eurasia/

I tried both linux and windows systems.

I imported such files yesterday with 6.4.1 on Linux, no problems occured.

comment:6 in reply to:  description ; Changed 8 years ago by neteler

Replying to MartinOver:

The import of srtm .hgt raster data is not working.

unzip: unknown command ERROR: The "unzip" program is required, please install it first

I have found it here: http://sourceforge.net/projects/mingw/files/MSYS/unzip/

Probably it would be an idea to copy it from the MSYS builder and add it to the winGRASS package?

comment:7 Changed 8 years ago by hamish

Milestone: 6.4.16.4.3
Summary: HGT Importzipped HGT Import fails on wingrass as "unzip" isn't in the package

6.4.2rc3 native wingrass installer still does not ship "unzip".

Hamish

comment:9 in reply to:  6 ; Changed 7 years ago by neteler

Version: 6.4.0svn-releasebranch64

An "easy" solution would be to add the "zip" package

http://sourceforge.net/projects/gnuwin32/files/zip/

to the MSYS package:

http://trac.osgeo.org/osgeo4w/wiki/pkg-msys

comment:10 in reply to:  9 ; Changed 7 years ago by martinl

Replying to neteler:

An "easy" solution would be to add the "zip" package

http://sourceforge.net/projects/gnuwin32/files/zip/

to the MSYS package:

http://trac.osgeo.org/osgeo4w/wiki/pkg-msys

done for msys-1.0.11-11 (1)

(1) http://trac.osgeo.org/osgeo4w/wiki/pkg-msys#Extrapackages

comment:11 in reply to:  10 Changed 7 years ago by martinl

Replying to martinl:

Replying to neteler:

An "easy" solution would be to add the "zip" package

http://sourceforge.net/projects/gnuwin32/files/zip/

to the MSYS package:

http://trac.osgeo.org/osgeo4w/wiki/pkg-msys

done for msys-1.0.11-11 (1)

(1) http://trac.osgeo.org/osgeo4w/wiki/pkg-msys#Extrapackages

such tools like zip and others should go probably to the new package (msys-tools or msys-extra)

http://trac.osgeo.org/osgeo4w/wiki/pkg-msys#TODO

comment:12 Changed 7 years ago by hamish

Keywords: unzip added

latest nightly wingrass installers still not shipping unzip.exe in extrabin or msys/bin.

comment:13 Changed 6 years ago by neteler

See also ticket #1952

comment:15 in reply to:  10 ; Changed 6 years ago by hellik

Replying to martinl:

Replying to neteler:

An "easy" solution would be to add the "zip" package

http://sourceforge.net/projects/gnuwin32/files/zip/

to the MSYS package:

http://trac.osgeo.org/osgeo4w/wiki/pkg-msys

done for msys-1.0.11-11 (1)

(1) http://trac.osgeo.org/osgeo4w/wiki/pkg-msys#Extrapackages

unzip [1] seems to be needed to close this ticket.

[1] http://gnuwin32.sourceforge.net/packages/unzip.htm

comment:16 in reply to:  15 Changed 6 years ago by martinl

Replying to hellik:

unzip [1] seems to be needed to close this ticket.

[1] http://gnuwin32.sourceforge.net/packages/unzip.htm

I have added unzip into msys package in 1.0.18-4 (1)

(1) http://trac.osgeo.org/osgeo4w/wiki/pkg-msys#Majorchanges

comment:17 Changed 6 years ago by neteler

Can the ticket be closed?

comment:18 in reply to:  17 Changed 6 years ago by hellik

Resolution: fixed
Status: newclosed

Replying to neteler:

Can the ticket be closed?

unzip available. closing ticket.

Note: See TracTickets for help on using tickets.