Opened 9 years ago

Closed 8 years ago

#1266 closed defect (fixed)

d.vect has problems

Reported by: akbgf Owned by: grass-dev@…
Priority: normal Milestone: 7.0.0
Component: Display Version: svn-trunk
Keywords: d.vect Cc:
CPU: x86-32 Platform: Linux

Description

Hi!

If using any selection option of d.vect (the list of category values or the where condition) GRASS-7.0 does not display the vector. The problem was in r45123 and is still there in r45168. If I start with no selection option except feature type selection, vectors are displayed. If I turn on a selection option of a vector - either the category list or the where condition, the vector is not displayed, other vectors are visible. After turning off the selection option, the vector is still non-visible. I tried to turn the vector on and off in the Layer Manager window and re-render map display - no effect. The vector is still there - I see the info of vector elements using v.what, however the vector is non-visible. I tested this problem on three different vectors having only areas, only lines, and only points.

An early version of GRASS-7 (of Dec 15 or 16, I guess) does not have this problem.

Andres Kuusk, Tartu Observatory, Estonia

Change History (7)

comment:1 Changed 9 years ago by akbgf

Hi!

In r45179 I see vectors again.
Thanks a lot!

Andres Kuusk

comment:2 Changed 9 years ago by martinl

Resolution: worksforme
Status: newclosed

comment:3 Changed 9 years ago by akbgf

Resolution: worksforme
Status: closedreopened

Hi!

I reopen the ticket, the problem is still there in r45179.
Only vectors from the old saved workspace are visible and selections can be used. If I remove vector maps of the loaded workspace in the Layer Manager window and load a vector again then it is visible. After turning on a selection by category the vector disappears from the display window. Really, it is still there, I see info about vector elements by v.what, however the vector is non-visible.
No error messages.
The r45185 has the same problem, r44607 has no such problem.

Andres Kuusk

comment:4 Changed 9 years ago by akbgf

I have tested r45185, r45214, r45303, r45357, r45362, r45396, r45405, r45592.
The problem is still there. Even if I change in the same d.vector window the vector map to another and remove all selection criteria (category and where conditions), this one is also non-visible. The only way to get it visible is to close the d.vector window and add in the Layer Manager a new vector layer. I can use selection criteria in r44607 which I am still using.
Andres Kuusk

comment:5 Changed 9 years ago by akbgf

The problem was still there in r45721, r45915, r46101, and r46198.
There is some change in r46317, now I got an error message.

% make clean
% svn cleanup
% svn up
At revision 46317.
% ./configure --enable-shared --without-mysql --without-sqlite --with-gdal --without-fftw --with-postgres --with-postgres-includes=/usr/include/pgsql --with-freetype-includes=/usr/include/freetype2 --with-freetype-libs=/usr/lib --with-geos=/usr/local/bin/geos-config
% make
% ./bin.i686-pc-linux-gnu/grass70

I load a raster and a vector of 64 areas.
The selection condition for a category (a present category) returns an error message in the Command console, no change in the display window.

Andres Kuusk


Traceback (most recent call last):
  File "/wrk/andres/sw/linux/grass70/dist.i686-pc-linux-
gnu/etc/gui/wxpython/gui_modules/layertree.py", line 233, in
OnIdle

self.mapdisplay.MapWindow.UpdateMap(render = True)
  File "/wrk/andres/sw/linux/grass70/dist.i686-pc-linux-
gnu/etc/gui/wxpython/gui_modules/mapdisp_window.py", line
666, in UpdateMap

windres = windres)
  File "/wrk/andres/sw/linux/grass70/dist.i686-pc-linux-
gnu/etc/gui/wxpython/gui_modules/render.py", line 868, in
Render

self._renderLayers(force, mapWindow, maps, masks, opacities)
  File "/wrk/andres/sw/linux/grass70/dist.i686-pc-linux-
gnu/etc/gui/wxpython/gui_modules/render.py", line 812, in
_renderLayers

if not layer.Render():
  File "/wrk/andres/sw/linux/grass70/dist.i686-pc-linux-
gnu/etc/gui/wxpython/gui_modules/render.py", line 158, in
Render

**self.cmd[1])
TypeError
:
'NoneType' object is not iterable 

comment:6 Changed 9 years ago by cmbarton

This may or may not be part of the same problem. But it seems close enough that I'll add this report here for now.

I just recompiled GRASS 7 at r47086,

Vectors do display after doing a v.build. But none of the column selection controls in d.vect seem to work. Likewise, the color by random colors does not work either. I had the vector disappear on me once, but it seems to display OK now.

Interestingly, I get the error reported in the comment preceding this one if I use d.thematic.area and get any of the inputs wrong.

Michael

comment:7 in reply to:  4 Changed 8 years ago by akbgf

Resolution: fixed
Status: reopenedclosed

Replying to akbgf:

I have tested r45185, r45214, r45303, r45357, r45362, r45396, r45405, r45592.

Several changes have been done in vector modules since that. I do not know which of them solved the problem but in r47868 vectors do not disappear any more.
Thanks to developers!

Andres Kuusk

Note: See TracTickets for help on using tickets.