Opened 9 years ago

Closed 3 years ago

#1242 closed defect (fixed)

vector fills and line widths not displaying in latlon regions

Reported by: cmbarton Owned by: grass-dev@…
Priority: normal Milestone: 7.0.5
Component: Display Version: svn-trunk
Keywords: vector, display, d.vect, d.northarrow, cartography, gsoc2016 Cc:
CPU: Unspecified Platform: Unspecified

Description

GRASS trunk svn updated today (16 Dec. 2010). Symbol fills do not display and changing line width has no effect. This all works fine in a non-latlon region.

Line colors and symbol size works OK in all.

Michael

Attachments (2)

ticket_1242.png (198.7 KB) - added by lucadelu 5 years ago.
double_north_arrow.jpg (60.4 KB) - added by cmbarton 5 years ago.
screenshot of double north arrow from GRASS trunk r62850

Download all attachments as: .zip

Change History (30)

comment:1 Changed 9 years ago by cmbarton

Component: DefaultVector
Keywords: vector display d.vect added

comment:2 Changed 9 years ago by martinl

Component: VectorDisplay

comment:3 Changed 6 years ago by hamish

Keywords: vector display d.vectvector, display, d.vect
Priority: normalcritical

Hi,

current status:

D_line_width() is not working in trunk for any projection type. tested: d.vect, d.grid, d.northarrow

symbol fill color is not working with lat/lon locations in trunk + d.vect, but it works ok in projected (spearfish) locations, and also from d.northarrow both in lat/lon and projected loc'ns.

In lat/lon locations d.northarrow is showing horizontal duplication of polyline-strings but not duplication of fill-areas for symbols. (I though we fixed that bug a year or two ago?) test region for this was not global or near the dateline.

Hamish

comment:4 Changed 5 years ago by wenzeslaus

I would test that but I don't understand what to try and what should I look for. Line width for vectors works for me (d.vect's width option). Running from GUI (with cairo driver I think).

comment:5 Changed 5 years ago by cmbarton

I just tested with GRASS 7.1 and it works fine on a set of points in a latlon region.

There is still a problem with north arrows, but I don't know if that is related or not. The arrow now looks OK, but it is still double.

comment:6 in reply to:  5 Changed 5 years ago by lucadelu

Replying to cmbarton:

I just tested with GRASS 7.1 and it works fine on a set of points in a latlon region.

There is still a problem with north arrows, but I don't know if that is related or not. The arrow now looks OK, but it is still double.

Tested with r62902 everything is working, could we close this ticket?

comment:7 Changed 5 years ago by cmbarton

Are the north arrows working? Last time I checked, they are still rendering as multiples. I have not tested this update from yesterday however.

Michael

Changed 5 years ago by lucadelu

Attachment: ticket_1242.png added

comment:8 in reply to:  7 Changed 5 years ago by lucadelu

Replying to cmbarton:

Are the north arrows working? Last time I checked, they are still rendering as multiples. I have not tested this update from yesterday however.

Michael

Yes, everything is working for me. Please see the attachment

Changed 5 years ago by cmbarton

Attachment: double_north_arrow.jpg added

screenshot of double north arrow from GRASS trunk r62850

comment:9 Changed 5 years ago by cmbarton

But did you try dragging the north arrow to the left to see if there is a duplicate? See the attached screenshot from version 62850.

Michael

comment:10 Changed 4 years ago by mlennert

I can confirm the duplication (or multiplication) of the north arrow. Here's a video showing the issue.

comment:11 Changed 4 years ago by cmbarton

Thanks Moritz. At least people don't think I'm crazy now (at least not in this case). Also, it's good to know that it's not just a Mac issue.

Michael

comment:12 Changed 4 years ago by mlennert

Does anyone have any idea where this might come from ?

comment:13 Changed 3 years ago by neteler

Component: DisplaywxGUI
Milestone: 7.0.07.0.3

I just tested with today's trunk version and relbranch70, the problem of the "replicated" north arrow in LatLong? locations is still there. However, setting the vector line width works.

Tested on Fedora 23, with Python: 2.7.10 and wxPython: 3.0.2.0.

comment:14 Changed 3 years ago by annakrat

Component: wxGUIDisplay
Keywords: d.northarrow added

comment:15 Changed 3 years ago by mlennert

Priority: criticalnormal

comment:16 Changed 3 years ago by neteler

Milestone: 7.0.3

Ticket retargeted after milestone closed

comment:17 Changed 3 years ago by neteler

Milestone: 7.0.4

Ticket retargeted after 7.0.3 milestone closed

comment:18 Changed 3 years ago by annakrat

Keywords: cartography gsoc2016 added
Milestone: 7.0.47.0.5

comment:19 Changed 3 years ago by wenzeslaus

See also #1410 for multiple north arrow displayed.

comment:20 Changed 3 years ago by annakrat

In 68531:

d.northarrow: fix multiplication of arrow in latlon regions, see #1242 and #1410

comment:21 in reply to:  20 Changed 3 years ago by annakrat

Replying to annakrat:

In 68531:

d.northarrow: fix multiplication of arrow in latlon regions, see #1242 and #1410

I removed D_setup (and left only D_setup_unity), which caused D_is_lat_lon() return true and caused the call of ll_wrap_path. The vertices had coordinates in pixels, not degrees, so ll_wrap_path computed nonsense. Please test, but it works for me.

comment:22 Changed 3 years ago by cmbarton

I'll recompile when I get back to the office next week and let you know. Thanks for fixing this.

Michael

comment:23 Changed 3 years ago by annakrat

In 68531:

d.northarrow: fix multiplication of arrow in latlon regions, see #1242 and #1410

comment:24 in reply to:  23 Changed 3 years ago by annakrat

Replying to annakrat:

In 68531:

d.northarrow: fix multiplication of arrow in latlon regions, see #1242 and #1410

Not sure what just happened, trac copied this automatic message at a moment when I committed something completely else (r68532). Might be related to mentioning wxWidgets ticket?

comment:25 Changed 3 years ago by cmbarton

I can confirm that these are all fixed in GRASS trunk r68543. No multiple north arrows, vector area fills and borders behave properly. Thanks much!

Michael

comment:26 Changed 3 years ago by annakrat

In 68550:

d.northarrow: fix multiplication of arrow in latlon regions, see #1242 and #1410 (merge from trunk, r68531)

comment:27 Changed 3 years ago by annakrat

In 68551:

d.northarrow: fix multiplication of arrow in latlon regions, see #1242 and #1410 (merge from trunk, r68531)

comment:28 Changed 3 years ago by annakrat

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.