Opened 9 years ago

Closed 9 years ago

#1240 closed defect (invalid)

wxGUI: attribute manager reports db connection not set while existing

Reported by: neteler Owned by: grass-dev@…
Priority: normal Milestone: 6.4.1
Component: wxGUI Version: svn-releasebranch64
Keywords: Cc:
CPU: x86-64 Platform: Linux

Description

I have a vector map with attributes in sqlite.db, while v.db.select works (even the wxGUI query tool), the attribute manager reports that no db connection is set. See screenshot.

Attachments (1)

wxgui_sqlite_attrib_bug.png (54.8 KB) - added by neteler 9 years ago.
sqlite connection bug

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by neteler

Attachment: wxgui_sqlite_attrib_bug.png added

sqlite connection bug

comment:1 Changed 9 years ago by neteler

Interestingly, also related modules are affected:

GRASS 6.4.1svn (patGB1):~ > v.db.addcol MRR1_09_marked_csv_lines_id_selected col="count integer"
ERROR: There is no table connected to this map! Run v.db.connect or
       v.db.addtable first.

GRASS 6.4.1svn (patGB1):~ > v.db.connect -p MRR1_09_marked_csv_lines_id_selected 
Vector map <MRR1_09_marked_csv_lines_id_selected@fra_sqlite> is connected
by:
layer <1> table <MRR1_09_marked_csv_lines_id_selected> in database </home/neteler/grassdata/patGB1/fra_sqlite/sqlite.db> through driver <sqlite> with key <cat>

comment:2 Changed 9 years ago by neteler

Resolution: invalid
Status: newclosed

Please ignore, caused by local modifications not yet submitted.

Note: See TracTickets for help on using tickets.