Opened 9 years ago

Closed 7 years ago

#1217 closed defect (fixed)

d.vect -a flag locks up the wxGUI on windows

Reported by: RenatoMacciotta Owned by: martinl
Priority: blocker Milestone: 6.4.3
Component: wxGUI Version: svn-develbranch6
Keywords: d.vect, wingrass Cc: grass-dev@…
CPU: x86-32 Platform: MSWindows XP

Description

Trying to define different colors for different areas using the -a flag and an attribute column (varchar 11) with rgb of the form rrr:ggg:bbb makes the software stop responding.

any suggestions? thank you

Change History (4)

comment:1 Changed 9 years ago by martinl

From the GUI (wxGUI or TCL/TK) or you are running d.vect from the command line?

comment:2 Changed 8 years ago by hamish

Component: DefaultwxGUI
CPU: Unspecifiedx86-32
Keywords: d.vect wingrass added
Milestone: 6.4.16.4.3
Platform: UnspecifiedMSWindows XP
Summary: d.vect -a flag crushes fro windows 64 bitd.vect -a flag locks up the wxGUI on windows
Version: unspecifiedsvn-develbranch6

Hi,

I can reproduce this in a recent nightly build of standalone wingrass 6.5svn on XP 32bit.

  • start up the wxgui in spearfish
  • add the vector fields map to the layer manager, but don't press ok yet
  • go to the colors tab and select the -a flag but don't add a RGB column name, just press ok
  • endless hourglass lockup for wxGUI. (can forcibly kill it by clicking the window decoration "X" then [ok] to 'not responding..')

and our old friend zombie dbf.exe is still lingering in the task manager even after grass exits. (see #1276)

on linux I get this error message in the wxGUI output console:

Command 'd.vect -a map=fields@PERMANENT' failed
Details: DBMI-DBF driver error:
Column 'GRASSRGB' not found
Error in db_open_select_cursor()
Color definition column (GRASSRGB) not a string. Column must
be of form RRR:GGG:BBB where RGB values range 0-255.

Hamish

comment:3 Changed 8 years ago by martinl

Cc: grass-dev@… added
Owner: changed from grass-dev@… to martinl
Priority: normalblocker
Status: newassigned

This bug should have been already fixed (r51009). Can you confirm it?

comment:4 Changed 7 years ago by neteler

Resolution: fixed
Status: assignedclosed

No answer, closing since it appears to be fixed. Reopen if needed.

Note: See TracTickets for help on using tickets.