Opened 9 years ago

Closed 9 years ago

#1129 closed defect (fixed)

Menu strings may be changed and not reflecting PO-files.

Reported by: naokiueda Owned by: grass-dev@…
Priority: normal Milestone: 6.4.0
Component: Translations Version: svn-releasebranch64
Keywords: i18n Cc:
CPU: Unspecified Platform: Unspecified

Description

We are GRASS Japanese translation team. In March 2010, out team translate GRASS Po-files into Japanese almost 100%. Now, with latest version, many 'menu strings' are back to English. That means relationship via Po-files are lost. Possible reason is a change in original English string. Not only for Japanese, but also other localization using pofiles should me effected by this recent change.

Change History (6)

comment:1 Changed 9 years ago by martinl

Resolution: invalid
Status: newclosed

What means 'many'? Yes, possibly some messages has been modified. Those message should be marked as 'fuzzy'. You need to correct them, it's not defect. Closing ticket as invalid.

Martin

comment:2 Changed 9 years ago by hamish

Component: defaultTranslations
Keywords: i18n added

... this sort of frustration is why many projects have a "strings freeze" once the RC cycle begins. For GRASS 6.4.1, .2, .3, .4 etc it should be quite stable though so as long as the stable branches are the focus of translation efforts everyone should be happy.

cheers, Hamish

comment:3 in reply to:  2 Changed 9 years ago by martinl

Replying to hamish:

... this sort of frustration is why many projects have a "strings freeze" once the RC cycle begins.

"strings freeze" is fine for RC. The problem is that RC stage should not be story for 1 year and half ;-)

comment:4 Changed 9 years ago by hamish

The problem is that RC stage should not be story for 1 year and half ;-)

... this one took so long because we wanted MS Windows to be an equal platform. We are finally near to that, but it took much longer than if we just going to release for UNIX, which was ready long ago. But if we hadn't done that the Windows release would still be a year away.

So you might say that that the problem is that we needed 4-5 low-level Windows devs a year+ ago, but that's a chicken and egg type bootstrapping problem to attract them before it's working solidly, all the while forcing them to exist in a unix enviro.

cheers, Hamish

comment:5 Changed 9 years ago by neteler

Resolution: invalid
Status: closedreopened

With apologize I open it again - indeed the menustrings.py messages where deleted in an incorrect template update (performed in an uncompiled GRASS source code tree). All grasswxpy_*.po files have been restored in SVN (except for DE, IT, PL which will follow shortly).

The closing of the ticket as invalid was due to a misunderstanding of the problem. And it is unrelated to the length of the RC cycle but a technical problem.

Markus

comment:6 Changed 9 years ago by neteler

Resolution: fixed
Status: reopenedclosed

All wxGUI menu strings should be back now in SVN, sorry for the temporary mess. The winGRASS snapshots in 1 day from now should contain again the translations. Closing ticket.

Note: See TracTickets for help on using tickets.