Opened 10 years ago

Last modified 4 years ago

#1056 new defect

OverflowError : long int too large to convert to int

Reported by: scizmeli Owned by: grass-dev@…
Priority: normal Milestone: 6.4.6
Component: wxGUI Version: 6.4.0 RCs
Keywords: georectifier Cc:
CPU: x86-32 Platform: Linux

Description

Hello,

I am running GRASS 6.4.0RC5 on Ubuntu Karmic.

I have been given a Mapinfo .tab vector file (polygons of administrative divisions of the city of Istanbul). Although the units seem to be in meters, the layer does contain no projection information. After many days of trial/error, I was unable to find its projection so I finally decided to rectify it so that I can use it with other GIS layers (EPSG 23035).

I first imported the layer into a XY location. I then created a georeferenced location (EPSG 23035) and started GRASS in it. When I start the georectifier, it all seems OK (except the fact that I had to first set the scale to 1:300,000,000 to be able to see the layer ;o(. any other way to zoom into that layer?) and I was able to set many GPCs. When it was time to go to bed, I saved the GCP's in a POINT file under the group I had created and went to bed. The next day, when I relaunch the georectifier under the same group, I get the following error :

OverflowError? : long int too large to convert to int

And the unprojected layer never gets displayed. I cannot continue my work. Trying the georectification with the same GCPs yield the same error as well.

Is this a bug? Let me know if I can furnish more info. Servet

Here is part of the output of ogrinfo -so : Had to open data source read-only. INFO: Open of `mahalle.tab'

using driver `MapInfo? File' successful.

Layer name: mahalle Geometry: Unknown (any) Feature Count: 639 Extent: (384799.325217, 4517717.000003) - (450634.029997, 4575689.999997) Layer SRS WKT: LOCAL_CS["Nonearth",

UNIT["Meter",1.0]]

...

Please find attached a gml extract of the dataset for your convenience. I was able to reproduce the error with this gml layer as well :

ogr2ogr test.gml input.tab -f "GML" -where "fid in (1)"

Here is the full error message :

GISDBASE: /C_DRIVE/Users/user/Desktop/... LOCATION_NAME: Istanbul_23035 MAPSET: PERMANENT MONITOR: x0 GRASS_GUI: wxpython Traceback (most recent call last):

File "/usr/lib/grass64/etc/wxpython/wxgui.py", line 367,

in OnGeorectify?

georect.GeorectWizard?(self)

File

"/usr/lib/grass64/etc/wxpython/gui_modules/georect.py", line 198, in init

self.gcpmgr.SetMapDisplay?(self.xy_mapdisp)

File

"/usr/lib/grass64/etc/wxpython/gui_modules/georect.py", line 794, in SetMapDisplay?

self.list.LoadData?()

File

"/usr/lib/grass64/etc/wxpython/gui_modules/georect.py", line 1290, in LoadData?

self.gcp.ReadGCPs()

File

"/usr/lib/grass64/etc/wxpython/gui_modules/georect.py", line 991, in ReadGCPs

sourceMapWin.UpdateMap?(render=False, renderVector=False)

File

"/usr/lib/grass64/etc/wxpython/gui_modules/mapdisp.py", line 811, in UpdateMap?

self.parent.gismanager.georectifying.DrawGCP(coordtype)

File

"/usr/lib/grass64/etc/wxpython/gui_modules/georect.py", line 881, in DrawGCP

5]})

File

"/usr/lib/grass64/etc/wxpython/gui_modules/mapdisp.py", line 1048, in DrawCross?

self.Draw(pdc, drawid=self.lineid, pdctype='line', coords=lineCoords)

File

"/usr/lib/grass64/etc/wxpython/gui_modules/mapdisp.py", line 404, in Draw

pdc.DrawLine?(coords[0], coords[1], coords[2], coords[3])

File "/usr/lib/python2.6/dist-

packages/wx-2.8-gtk2-unicode/wx/_gdi.py", line 7191, in DrawLine?

return _gdi_.PseudoDC_DrawLine(*args, kwargs) OverflowError? : long int too large to convert to int

Attachments (1)

test.gml (48.6 KB) - added by scizmeli 10 years ago.
ogr2ogr test.gml input.tab -f "GML" -where "fid in (1)"

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by scizmeli

Attachment: test.gml added

ogr2ogr test.gml input.tab -f "GML" -where "fid in (1)"

comment:1 in reply to:  description ; Changed 10 years ago by scizmeli

By the way, the old interface gis.m seems to be working well.

comment:2 Changed 10 years ago by scizmeli

CPU: Unspecifiedx86-32

comment:3 in reply to:  1 Changed 10 years ago by scizmeli

Well, no, the old GUI does not work either. With the old GUI, I can get past the problem I have with the new GUI but later, I run into the problem :

can't read "b1coords" no such variable

I guess no solution is being offered for this problem (http://www.mail-archive.com/grass-user@lists.osgeo.org/msg11373.html) and people are being referred to the new GUI. So this means that none of the GUIs are working for now for me! ;o(

comment:4 Changed 9 years ago by scizmeli

Bump! No one willing to take a look at this bug?

comment:5 Changed 8 years ago by hamish

Component: DefaultwxGUI
Keywords: georectifier added
Platform: UnspecifiedLinux

are things any better with 6.4.2rc3?

comment:6 Changed 4 years ago by neteler

Milestone: 6.4.06.4.6
Note: See TracTickets for help on using tickets.