Opened 10 years ago

Closed 9 years ago

#1038 closed defect (worksforme)

v.surf.rst fails in Windows 7 with "Access is denied"

Reported by: marisn Owned by: grass-dev@…
Priority: critical Milestone: 6.4.0
Component: Vector Version: 6.4.0 RCs
Keywords: v.surf.rst, wingrass Cc:
CPU: Unspecified Platform: MSWindows 7

Description

Today one of my students got hit by Windows 7 permission issue. (IIRC it also applies to XP/Vista)

Launching v.surf.rst from WxGUI fails with "Access is denied".

Problem was solved by allowing User to modify "C:\Program Files\GRASS..." folder and it's contents. Still it's not an option, as User might not have rights to change access restrictions in "Program Files" also it's a BAD design to write anything in "Program Files" during normal usage.

WinGRASS 6.4.0 RC6 on Windows 7

Change History (5)

comment:1 Changed 10 years ago by hamish

what's the last few messages you see before it dies?

(--verbose + DEBUG=5 from the command line)

No idea if there is a way to run a strace on MS Windows, probably some app to do that out there.

It may not be trying to write a file; "Access is denied" could mean the file is not-readable, doesn't exist, etc.

Hamish

ps- module name and wingrass as keywords so the filters pick them up

comment:2 Changed 10 years ago by hamish

Keywords: v.surf.rst wingrass added

Hi,

I've no way of testing on XP right now. Can anyone reproduce this & provide debugging output?

Hamish

comment:3 in reply to:  2 Changed 10 years ago by hellik

Replying to hamish:

Hi,

I've no way of testing on XP right now. Can anyone reproduce this & provide debugging output?

Hamish

taken from the dev-ml (http://lists.osgeo.org/pipermail/grass-dev/2010-May/050270.html)

> > 
>> 
>> [*] ... can someone test if 6.4's v.surf.rst works on XP/Vista/7?
>
>we have been running it all semester on XP/Vista/7 without any complaints, 
>but I would have to specifically
>check who actually ran it with GRASS installed under Program Files. 
 
tested with the nightly-build  WinGRASS-6.4.SVN-r42075-1-Setup.exe 
(installed in c:\Program Files\ in WinVista32) and the example from the manual:

Spearfish example (we simulate randomly distributed elevation measures):

g.region rast=elevation.10m -p
# random elevation extraction
r.random elevation.10m vector_output=elevrand n=200
v.info -c elevrand
v.db.select elevrand

# interpolation based on all points
v.surf.rst elevrand zcol=value elev=elev_full
r.colors elev_full rast=elevation.10m
d.rast elev_full
d.vect elevrand

# interpolation based on subset of points (only those over 1300m/asl)
v.surf.rst elevrand zcol=value elev=elev_partial where="value > 1300"
r.colors elev_partial rast=elevation.10m
d.rast elev_partial
d.vect elevrand where="value > 1300"

v.surf.rst is working.

tried with the spearfish-example in the wx-gui-command-line and also the wx-gui for v.surf.rst in a WinVista32-box (Grass64 installed in the default c:\Program Files\ without any modifications).

v.surf.rst is working in both ways.

best regards Helmut

comment:4 Changed 9 years ago by neteler

Seems to be solved?

comment:5 Changed 9 years ago by marisn

Resolution: worksforme
Status: newclosed

I have no access to Windows 7, as problem was on one of my students laptops. Tested on Vista with account without write permission to GISBASE and everything was working fine.

Closing and let's hope for the best.

Note: See TracTickets for help on using tickets.