Opened 10 years ago

Closed 10 years ago

#1010 closed defect (duplicate)

WxGUI d.vect/rast modules stuck in running state with d.mon

Reported by: marisn Owned by: martinl
Priority: normal Milestone: 6.4.0
Component: wxGUI Version: svn-releasebranch64
Keywords: d.mon Cc: grass-dev@…
CPU: x86-64 Platform: Linux

Description

Start monitor (d.mon x0); Launch d.rast module (with new wx based UI). Choose raster to display. Press "RUN". No output in "command output" tab and module doesn't stop running (only "STOP" button is active). Still module has done it's job - there is content in monitor. Only way how to close this window is by window close button, as "STOP" button emits only errors:

GRASS 6.4.0svn (personal_spearfish_60):~/soft/grass_64 > d.mon x0
using default visual which is TrueColor
ncolors: 16777216
Graphics driver [x0] started
GRASS 6.4.0svn (personal_spearfish_60):~/soft/grass_64 > d.vect
Traceback (most recent call last):
  File "/home/maris/soft/grass_64/dist.x86_64-unknown-linux-gnu/etc/wxpython/gui_modules/goutput.py", line 486, in OnCmdAbort
    self.cmdThread.abort()
  File "/home/maris/soft/grass_64/dist.x86_64-unknown-linux-gnu/etc/wxpython/gui_modules/goutput.py", line 108, in abort
    self.requestCmd.abort()
AttributeError: 'CmdThread' object has no attribute 'requestCmd'

Change History (2)

comment:1 Changed 10 years ago by martinl

Cc: grass-dev@… added
Keywords: wxgui removed
Owner: changed from grass-dev@… to martinl
Status: newassigned

comment:2 Changed 10 years ago by hamish

Resolution: duplicate
Status: assignedclosed

dupe of #928, but interesting a builtin C module from the command libe triggers it. (I can reproduce)

Note: See TracTickets for help on using tickets.