Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#693 closed defect (duplicate)

Buffer operation uses excessive amount of memory

Reported by: wonder Owned by: geos-devel@…
Priority: major Milestone: 3.6.1
Component: Default Version: 3.4.2
Severity: Unassigned Keywords:
Cc:

Description

When doing a buffer operation on a more complex linestring, the memory consumption rises to many hundreds of megabytes, eventually exhausting RAM and locking up the system completely.

SAGA builds the same buffer with very low memory usage.

Please see the attached example code for a reproducible example.

Originally reported in QGIS: http://hub.qgis.org/issues/10356

Attachments (1)

buffer-test.zip (164.2 KB) - added by wonder 6 years ago.
Reproducible test case

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by wonder

Attachment: buffer-test.zip added

Reproducible test case

comment:1 Changed 6 years ago by strk

Resolution: duplicate
Status: newclosed

Duplicate of #344

comment:2 Changed 4 years ago by strk

Milestone: 3.4.33.6.1

Ticket retargeted after milestone deleted

Note: See TracTickets for help on using tickets.