Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#616 closed defect (wontfix)

Build failure with VS2012

Reported by: jluis Owned by: geos-devel@…
Priority: major Milestone: 3.4.0
Component: Default Version: master
Severity: Unassigned Keywords:
Cc:

Description (last modified by mloskot)

Using cmake and VS2012 fails with

C:\programs\compa_libs\geos_SVN\src\operation\buffer\BufferOp.cpp(91) : error C2589: '(' : illegal token on right side of '::'
C:\programs\compa_libs\geos_SVN\src\operation\buffer\BufferOp.cpp(91) : error C2059: syntax error : '::'

it also prints the following warning (I think it didn't when I tried to build version 3.3.5)

C:\programs\compa_libs\geos_SVN\include\geos/precision/GeometryPrecisionReducer.h(154) : warning C4512: 'geos::precision::GeometryPrecisionReducer' : assignment operator could not be generated
        C:\programs\compa_libs\geos_SVN\include\geos/precision/GeometryPrecisionReducer.h(42) : see declaration of 'geos::precision::GeometryPrecisionReducer'

Change History (9)

comment:1 Changed 8 years ago by strk

Milestone: 3.3.73.4.0

I thought this was fixed. 3.3.7 is out already. Have you tried it ?

comment:2 Changed 8 years ago by jluis

Sorry for the wrong milestone. It was already set to 3.3.7 and I didn't notice.

No, I didn't try 3.3.7 as I am using the trunk version (r3754). BTW, I changed 'std::max' to 'max' and the build continued much further but still failed with

C:\programs\compa_libs\geos_SVN\capi\geos_ts_c.cpp(97) : fatal error C1083: Cannot open include file: '../geos_svn_revision.h': No such file or directory

comment:3 Changed 8 years ago by mloskot

Description: modified (diff)

comment:4 Changed 8 years ago by mloskot

If you searched the archive, you will find #556

comment:5 Changed 8 years ago by strk

Resolution: wontfix
Status: newclosed

Oh, right, so this is another wontfix (unless patch is sent)

comment:6 Changed 8 years ago by jluis

Sorry, 'wontfix' why?

Issue #556 refers to the non generating of the geos_svn_revision.h file but this ticket is about error at line 91 of BufferOp?.cpp which has nothing to do with the header file.

comment:7 Changed 8 years ago by strk

because of cmake use, it's not supported as a build tool. Can you get a GNU like tool chain ?

comment:8 Changed 8 years ago by jluis

I could but that is not what I want/need, which is a VS build.

comment:9 Changed 8 years ago by mloskot

@jluis

First, instead of changing std::max you should fix your build configuration on Windows as this issue is related to buggy headers on Windows. So, use #define NOMINMAX, etc. Seek for details on MSDN.

Second, regarding geos_svn_revision.h, I updated the CMake wiki pages to indicate these files should be created manually: BuildingOnWindowsWithCMake and BuildingOnUnixWithCMake.

Note: See TracTickets for help on using tickets.