Opened 9 years ago

Closed 6 years ago

Last modified 4 years ago

#578 closed defect (fixed)

NMake fails to build on Windows 8 Release Preview

Reported by: scook Owned by: mloskot
Priority: trivial Milestone: 3.5.0
Component: Default Version: master
Severity: Unassigned Keywords: nmake, Window 8 Release Preview
Cc:

Description

Steps to reproduce error: 1) Perform svn-checkout of http://svn.osgeo.org/geos/trunk to a local folder 2) Open VS2012 x86 Native Tools command prompt 3) Change directory to local folder where files were downloaded to in step 1 4) Run "nmake /f makefile.vc MSVC_VER=1700"

Receive the following error: * GEOS Build Configuration * * Setting BUILD_DEBUG NO * Setting ENABLE_INLINE NO * Setting BUILD_BATCH NO * Cannot determined Visual C++ version .\nmake.opt(102) : fatal error U1050: * Aborting make job Stop.

Steps to fix bug: 1) Update nmake.opt by inserting the following at line 95 (between the lines that read "GEOS_MSC = 1700" and "!ELSE"):

!ELSEIF "$(_NMAKE_VER)" == "11.00.50522.1" GEOS_MSVC = 11.0 GEOS_MSC = 1700

Change History (10)

comment:1 in reply to:  description Changed 9 years ago by scook

Making the ticket easier to read since I didn't use Preview before submitting.

Steps to reproduce error:
1) Perform svn-checkout of http://svn.osgeo.org/geos/trunk to a local folder
2) Open VS2012 x86 Native Tools command prompt
3) Change directory to local folder where files were downloaded to in step 1
4) Run "nmake /f makefile.vc MSVC_VER=1700"

Receive the following error:

* GEOS Build Configuration *
* Setting BUILD_DEBUG NO
* Setting ENABLE_INLINE NO
* Setting BUILD_BATCH NO
* Cannot determined Visual C++ version
.\nmake.opt(102) : fatal error U1050:
* Aborting make job
Stop.

Steps to fix bug:
1) Update nmake.opt by inserting the following at line 95 (between the lines >that read "GEOS_MSC = 1700" and "!ELSE"):

!ELSEIF "$(_NMAKE_VER)" == "11.00.50522.1"
GEOS_MSVC = 11.0
GEOS_MSC = 1700

comment:2 Changed 9 years ago by strk

Milestone: 3.3.53.4.0

comment:3 Changed 8 years ago by robe

Milestone: 3.4.03.5.0

I'm pushing we just use CMake for windows builds.

comment:4 Changed 6 years ago by robe

Milestone: 3.5.0GEOS Future

comment:5 Changed 6 years ago by mloskot

Milestone: GEOS Future3.5.0
Owner: changed from geos-devel@… to mloskot
Status: newassigned

comment:6 Changed 6 years ago by mloskot

Fixed in trunk (r4058)

comment:7 Changed 6 years ago by mloskot

Resolution: fixed
Status: assignedclosed

comment:8 Changed 4 years ago by Mateusz Loskot <mateusz@…>

In cc8c5a0/git:

Update nmake.opt to recognize NMAKE 11.00.50522.1.
Fixes #578.

git-svn-id: http://svn.osgeo.org/geos/trunk@4058 5242fede-7e19-0410-aef8-94bd7d2200fb

comment:9 Changed 4 years ago by Mateusz Loskot <mateusz@…>

In cc8c5a0/git:

Update nmake.opt to recognize NMAKE 11.00.50522.1.
Fixes #578.

git-svn-id: http://svn.osgeo.org/geos/trunk@4058 5242fede-7e19-0410-aef8-94bd7d2200fb

comment:10 Changed 4 years ago by Mateusz Loskot <mateusz@…>

In cc8c5a0/git:

Update nmake.opt to recognize NMAKE 11.00.50522.1.
Fixes #578.

git-svn-id: http://svn.osgeo.org/geos/trunk@4058 5242fede-7e19-0410-aef8-94bd7d2200fb

Note: See TracTickets for help on using tickets.