Opened 6 years ago

Closed 6 years ago

#551 closed defect (duplicate)

Segfault in Distance functions

Reported by: pramsey Owned by: geos-devel@…
Priority: major Milestone: 3.3.4
Component: Default Version: 3.3.3
Severity: Unassigned Keywords:
Cc:

Description

In Centos 6, 64bit,

./XMLTester ./tests/general/TestWithinDistance.xml

also in the TestDistance?.xml function. Backtrace:

Program received signal SIGABRT, Aborted.
0x00110424 in __kernel_vsyscall ()
Missing separate debuginfos, use: debuginfo-install glibc-2.12-1.47.el6_2.9.i686 libgcc-4.4.6-3.el6.i686 libstdc++-4.4.6-3.el6.i686
(gdb) bt
#0  0x00110424 in __kernel_vsyscall ()
#1  0x00492af1 in raise () from /lib/libc.so.6
#2  0x004943ca in abort () from /lib/libc.so.6
#3  0x0048bdcb in __assert_fail_base () from /lib/libc.so.6
#4  0x0048be86 in __assert_fail () from /lib/libc.so.6
#5  0x0033637d in geos::geom::GeometryComponentFilter::filter_ro(geos::geom::Geometry const*) ()
   from /home/pramsey/suite/installer/linux/rpm/rpmbuild/BUILD/geos-3.3.3/src/.libs/libgeos-3.3.3.so
#6  0x003409ef in geos::geom::Point::apply_ro(geos::geom::GeometryComponentFilter*) const ()
   from /home/pramsey/suite/installer/linux/rpm/rpmbuild/BUILD/geos-3.3.3/src/.libs/libgeos-3.3.3.so
#7  0x003a4a33 in geos::operation::distance::DistanceOp::computeFacetDistance() ()
   from /home/pramsey/suite/installer/linux/rpm/rpmbuild/BUILD/geos-3.3.3/src/.libs/libgeos-3.3.3.so
#8  0x003a4e0b in geos::operation::distance::DistanceOp::computeMinDistance() ()
   from /home/pramsey/suite/installer/linux/rpm/rpmbuild/BUILD/geos-3.3.3/src/.libs/libgeos-3.3.3.so
#9  0x003a50f1 in geos::operation::distance::DistanceOp::distance() ()
   from /home/pramsey/suite/installer/linux/rpm/rpmbuild/BUILD/geos-3.3.3/src/.libs/libgeos-3.3.3.so
#10 0x003a5449 in geos::operation::distance::DistanceOp::distance(geos::geom::Geometry const*, geos::geom::Geometry const*) () from /home/pramsey/suite/installer/linux/rpm/rpmbuild/BUILD/geos-3.3.3/src/.libs/libgeos-3.3.3.so
#11 0x0032fa45 in geos::geom::Geometry::distance(geos::geom::Geometry const*) const ()
   from /home/pramsey/suite/installer/linux/rpm/rpmbuild/BUILD/geos-3.3.3/src/.libs/libgeos-3.3.3.so
#12 0x00330511 in geos::geom::Geometry::isWithinDistance(geos::geom::Geometry const*, double) const ()
   from /home/pramsey/suite/installer/linux/rpm/rpmbuild/BUILD/geos-3.3.3/src/.libs/libgeos-3.3.3.so
#13 0x0805250e in XMLTester::parseTest (this=0xbffff10c, node=0x806b308) at XMLTester.cpp:1153
#14 0x0805409c in XMLTester::parseCase (this=0xbffff10c, node=0x806afc0) at XMLTester.cpp:644
#15 0x080546bc in XMLTester::parseRun (this=0xbffff10c, node=0x806ad60) at XMLTester.cpp:449
#16 0x08054c4c in XMLTester::run (this=0xbffff10c, source="./tests/general/TestWithinDistance.xml") at XMLTester.cpp:399
#17 0x080550f5 in main (argC=2, argV=0xbffff274) at XMLTester.cpp:1507

Change History (2)

comment:1 Changed 6 years ago by strk

Sounds like a compiler bug. Can you reproduce with debugging symbols on,and maybe different optimization flags ?

comment:2 Changed 6 years ago by strk

Resolution: duplicate
Status: newclosed

Duplicate of #535

Note: See TracTickets for help on using tickets.