Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#479 closed defect (invalid)

llvm-gcc on OS X Lion does not link

Reported by: hobu Owned by: geos-devel@…
Priority: minor Milestone: 3.3.1
Component: Default Version: 3.3.0
Severity: Unassigned Keywords:
Cc: erictheise

Description

Undefined symbols for architecture x86_64:
  "__ZNSt8auto_ptrIN4geos4geom8EnvelopeEEcvSt12auto_ptr_refIT_EIS2_EEv", referenced from:
      virtual thunk to geos::geom::GeometryCollection::computeEnvelopeInternal() constin GeometryCollection.o
  "std::auto_ptr<geos::geom::Envelope>::auto_ptr(std::auto_ptr_ref<geos::geom::Envelope>)", referenced from:
      virtual thunk to geos::geom::GeometryCollection::computeEnvelopeInternal() constin GeometryCollection.o
ld: symbol(s) not found for architecture x86_64
collect2: ld returned 1 exit status

Change History (5)

comment:1 Changed 9 years ago by strk

Sounds like a compiler bug to me (didn't instantiate std::auto_ptr<geos::geom::Envelope> class)

comment:2 Changed 9 years ago by strk

Resolution: invalid
Status: newclosed

comment:3 Changed 9 years ago by erictheise

Cc: erictheise added

I just ran across this problem with 3.3.1 on OS X Lion, too. I've gone back to 3.2.3 (which has its own problems: "SWIG is disabled, can't build geos_wrap.cxx" when enabling ruby and/or python bindings), so I'm wondering what others are doing to compile the current version on OS X.

comment:4 Changed 9 years ago by kyngchaos

Force it to compile with gcc. With cmake configuration, add:

-D CMAKE_CXX_COMPILER="/usr/bin/g++-4.2" -D CMAKE_C_COMPILER="/usr/bin/gcc-4.2"

And, according to the readme, the python bindings are not supported any more, and the devs suggest using Shapely or ctypes.

comment:5 Changed 9 years ago by hobu

Duplicate of #463. Short answer is to use clang with svn trunk to get going on Lion.

Note: See TracTickets for help on using tickets.