Opened 13 years ago

Closed 12 years ago

#283 closed defect (fixed)

Patch: ported linearref from JTS

Reported by: novalis Owned by: geos-devel@…
Priority: blocker Milestone: 3.2.0
Component: Default Version: main
Severity: Unassigned Keywords:
Cc:

Description

I have ported the linearref code from JTS to GEOS.

Attachments (1)

linearref.patch (88.3 KB ) - added by novalis 13 years ago.
patch to add linearref support

Download all attachments as: .zip

Change History (6)

by novalis, 13 years ago

Attachment: linearref.patch added

patch to add linearref support

comment:1 by pramsey, 13 years ago

Resolution: fixed
Status: newclosed

Lovely. In trunk at r2619

comment:2 by strk, 13 years ago

Resolution: fixed
Status: closedreopened

FYI: the code applied contains memory errors and leaks. I'll spend some hours on that, but dunno if I've enough funding to complete it.

comment:3 by strk, 13 years ago

Resolution: fixed
Status: reopenedclosed

alright, memory error is gone as of r2697. I'll close this and open a new one for the leaks.

comment:4 by strk, 12 years ago

Priority: majorblocker
Resolution: fixed
Status: closedreopened

GEOSInterpolate, like GEOSProject, segfaults. I fixed GEOSProject, but don't have time/funding to fix GEOSInterpolate.

When new code is added, it should come with unit testing. It would have been easy to catch such situations.

Also in this case the segfault is triggered by calling the function against a POINT, so the root cause might be the same (not checking that input is a LINESTRING)

comment:5 by strk, 12 years ago

Resolution: fixed
Status: reopenedclosed

Filed another ticket for the segfault: #353

Note: See TracTickets for help on using tickets.