wiki:Release/1.6/Notes

1.6 Release Notes

Supported Browsers

GeoPrisma has been tested and fully supports the following browsers :

  • Internet Explorer 7, 8 and 9
  • Firefox 3.6+

Other browsers were not tested so can't be qualified as fully supported.

Supported JavaScript Libraries

The following libraries (version) are packaged with GeoPrisma 1.6 :

  • OpenLayers (2.12-rc7, updated)
  • Proj4js (1.0.1)
  • MapFish (trunk, revision 3862)
  • GeoExt (trunk, revision 2865)
  • GeoExt-ux (trunk, revision 2865)
  • GeoExt-ux-AttributeFilterPanel (trunk, revision 2865)
  • GeoExt-ux-FeatureEditing (trunk, revision 2865)
  • GeoExt-ux-LayerManager (trunk, revision 2865)
  • GeoExt-ux-LayerTreeBuilder (trunk, revision 2865)
  • GeoExt-ux-ShortcutCombo (trunk, revision 2865)
  • GeoExt-ux-Styler (trunk, revision 2865)
  • GeoExt-ux-WFSTFeatureEditing (trunk, revision 2865)
  • GeoExt-ux-WMSBrowser (trunk, revision 2883)
  • GeoExt-ux-ZoomTo (trunk, revision 2882)

The following libraries (version) were tested with GeoPrisma 1.6 :

  • ExtJS (3.4.0)

Softwares

The following softwares can be safely used with this release of GeoPrisma as its services :

Tile providers

The following tile providers are supported by this release of GeoPrisma as "gymo" services :

  • GoogleMaps (3.5+)
  • OpenStreetMaps

The following tile providers are deprecated in this release of GeoPrisma :

  • YahooMaps (deprecated)

Widgets

Widgets that are new or received big or important updates have a notice in parenthesis.

Stable

  • api
  • applyfilter
  • featurepanel_selector
  • geoextprintform (updated)
  • geoexttoolbar
  • geoextux_layertreebuilder
  • geoextux_redliningpanel
  • geoextux_shortcutcombo
  • geoextux_zoomto
  • getmouseposition
  • htwindow
  • initialview
  • layer
  • mappanel
  • measuretool
  • mouseposition
  • querybyrect
  • queryonclick
  • queryonclickwizard
  • resultextgrid
  • resultvectorlayer
  • scale
  • shortcut
  • toggle
  • unselectall
  • vectorlayer
  • zoomslider

Unstable

  • attributefilterpanel
  • editfeature_confirm
  • editfeature_copy
  • editfeature_create
  • editfeature_delete
  • editfeature_drag
  • editfeature_update
  • editfeature_split
  • filetreepanel
  • featurepanel_customform
  • featurepanel_attributeform
  • featurepanel_form
  • geoextux_printpreview
  • geoextux_wmsbrowser
  • geoextux_geonamessearchcombo
  • keepactivesession
  • pdfprint
  • templatepopup
  • wfsfilterbuilder

Deprecated

  • map
  • mapfishlayertree
  • mapfishrecenter
  • wmslayeradder

Migration Guide : GeoPrisma 1.4 to 1.6

  • OpenLayers 2.11 is not longer supported. If you do not use GeoPrisma included libraries, you need to upgrade to OpenLayers 2.12-rc7.
  • Lots of new features were added to the GeoExtPrintForm widgets. In order for them to work properly, you need to have a MapFishPrint config.yaml including the following blocks. See http://www.mapfish.org/doc/print/configuration.html to learn more.
    • mapTitle
    • mapSubTitle
    • comments
    • legends
    • map with overviewMap set
  • New widgets in this release : OverviewMap. Make sure to add them to your .xslt template files.

Other notes

  • OpenLayers 2.12-rc7 is now used, which has many files that were deprecated and moved to a single deprecated.js file inside its lib directory. This file is included when using the printAllLibSources with pVersion parameter equal to 'deprecated'.

HISTORY.TXT

See HISTORY.TXT for a complete detail for of each release for the 1.6 branch.

Last modified 8 years ago Last modified on Nov 27, 2012, 5:26:04 AM