wiki:TestMatrix150

Please use this page to list reports of testing GDAL1.5.0 betas and release candidates. You will need an OSGeo Userid to login and edit this page.

For each report line, indicate who is reporting (OSGeo userid or name, or email), what beta/RC was tested, and brief info on what options were tried. List bug numbers for any bugs filed.

The 1.5.0 autotest can be download from subversion or http://download.osgeo.org/gdal/gdalautotest-1.5.0b1.tar.gz. Some information on running the autotest suite is available in the TestingNotes.

Platform Builds

Please indicate what options were tried (extra drivers, script bindings, etc), was autotest run.

  • Win32 / MSVC (indicate MSVC version)
    • warmerdam, VC7.1, beta1 (continuous), buildbot build, autotest works fine, need to list optional drivers...
    • warmerdam, VC8.0, beta1 (continuous), buildbot build, autotest works fine, need to list optional drivers...
    • warmerdam, VC6 (beta2): found several problems (#2106) which should be fixed for RC1. Minimal build and modest testing.
  • Win64 / MSVC
    • warmerdam, VC8.0, beta1 (continuous), buildbot build, autotest works fine, need to list optional drivers...
  • Win32 / Cygwin
    • Built with latest cygwin and a minimal GDAL build. Build went fine, and minimal interactive testing of executables went fine.
  • Win32 / MSYS/MINGW
    • ajolma, plain configure works, finds postgis: --with-pg=/c/Progra~1/PostgreSQL/8.2/bin/pg_config.exe, finds expat: --with-expat=/mingw, finds external libtiff from GTK+ but fails in compile for not having c:/GTK/include, compiles when that's added to GDALmake.opt, linking fails on "Envisat.o not found" works if GDAL_ROOT is replaced with "." in GNUmakefile, Perl bindings complain on clean.bat not in MANIFEST (fixed now in trunk), Perl tests ok
  • Linux Intel 32bit (list gcc version)
    • warmerdam, gcc 4.0.1, beta1 (continuous), buildbot telascience-full build, autotest works fine, Python 2.4, Mono
    • rouault, gcc 4.1.3, r13274 (post-beta1), Ubuntu 7.10 i386

./configure --without-libtool --with-libtiff=internal --with-sqlite --without-hdf4 --without-hdf5 --with-hide-internal-symbols=yes --with-python

drivers/libraries supported : NETCDF, OGDI, JASPER, CURL, POSTGRESQL, XERCES, EXPAT, ODBC, PGEO, SQLITE, GEOS autotest works fine (680 succeeded, 192 skipped, 0 failed)

  • Linux Intel 64bit (list gcc version)
    • pvachon, beta1, beta2, latest trunk constantly, SuSE Linux Enterprise Server 9.2, icc version 8.1, Itanium2 (IA64) (Silicon Graphics Altix)
      • build failed at linking stage due to unresolved symbols. I will look into this further when I have time.
  • Linux AMD 64bit
    • cartrite, beta1, beta2, openSuse10.2 x86_64, gcc version 4.1.2 20061115
      • ./configure --with-hdf4 --with-hdf5 --with-perl --with-python Build successful but link failed grep: /usr/lib/libSM.la: No such file or directory
      • /usr/bin/sed: can't read /usr/lib/libSM.la: No such file or directory libtool: link: `/usr/lib/libSM.la' is not a valid libtool archive
      • Link also fails for same reason with ./configure and no other options. gdal-1.4.4 builds and links successfully.
      • The 1.5 beta packages are building with 64 bit devel libs but tries to link to 32 bit devel libs.
      • ./configure --without-libtool --with-python --with-libtiff=internal works, autotest reports Succeeded: 646 Failed:1 (0 blew exceptions)
      • Script: ogr/ogr_geom.py TEST: ogr_geom_empty ... fail IsEmpty? returning false for an empty geometry Skipped: 222
    • pvachon, beta1, beta2, trunk
      • openSuSE 10.3 x86_64, gcc version 4.2.1, autotest works fine
      • Ubuntu 7.10 x86_64, gcc version 4.1.3, autotest works fine
  • Solaris (indicate OS version, toolchain, Sparc vs. Intel)
    • no reports
  • MacOS X (indicate version, PPC vs. Intel, normal vs. framework)
    • kyngchaos, built framework PPC+Intel/32+64bit on OSX 10.5 (Leopard), tested Intel 32bit on Leopard, all formats possible on OSX (ie no win-only deps), except no Xerces support since it can't be built 64bit, and no OCI which is PPC-only. GRASS, ECW, MrSID as plugins. Can test Intel and PPC 32bit on OSX 10.4 (Tiger) later. Can only do program run tests in 64bit mode since Python doesn't run 64bits (may be able to work out something later).
  • MacOS X 10.4.11 Intel, normal
    • springmeyer, built well (1.5.0b2) with gcc 4.0.1, python 2.5: ./configure --with-python --with-libtiff=internal --with-png=internal --with-threads --with-static-proj4=/usr/local --with-mrsid=/usr/local/Geo_DSDK-6.0.7.1407. Configure automatically found and enabled CURL, PostgreSQL, PGeo, and SQLite support.
      • One warning in configure output: "config.status: WARNING: GDALmake.opt.in seems to ignore the --datarootdir setting"
      • autotest gave "Test Script: osr/osr_usgs.py, Succeeded: 658, Failed: 1 (0 blew exceptions), Skipped: 217"
      • minor autotest failure was that "projections differ" by one line: "PARAMETER["latitude_of_origin",1]" in the "old" EPSG 9001
  • Other Unix (list OS, toolchain, CPU)
    • pvachon, trunk
      • IRIX 6.5.28, MIPSpro 7.4.4
        • build failure due to the mixture of C and C++/stl and assumptions about the default namespace. These can be kludged (see [IRIXBuild], but linking still fails (and I've lacked time to really try to fix it).

Bindings

  • C# / Win32
    • warmerdam: beta1 (continuous), buildbot (vc71, vc8, etc), build and autotests are fine.
  • C# / Linux-mono
    • warmerdam: beta1 (continuous), buildbot telascience-full, build and autotests are fine.
  • Python Win32 / (indicate Python version, NG vs. OG, install method)
    • no reports
  • Python Unix-like / (indicate Python version, NG vs. OG, install method)
    • rouault: r13274 (post-beta1), Ubuntu 7.10 i386, python 2.5, NG, install method : make install, autotests are fine
    • kyngchaos: autotests run on OSX. Python 2.5 Leopard Intel 32bit. (Tiger test later)
  • Perl Win32
    • no reports
  • Perl Unix-like
    • no reports
  • Java
    • no reports
  • Ruby
    • no reports

Drivers

For driver testing give a brief sense of what testing was done, what platform, and if appropriate what version of external libraries was used. Mostly we list "problem drivers" or very new drivers.

Raster (GDAL)

  • HDF4
  • HDF5
    • no reports
  • ECW
    • kyngchaos: r1655 OSX - ECW library can't write
  • JP2KAK
    • warmerdam: autotest works fine with win32 and linux FWTools builds
  • MrSID
    • kyngchaos: OSX - MrSID libraries only available 32bit, so can't test 64bit OSX.
    • warmerdam: autotest works fine with win32 and linux FWTools builds.
  • ADRG
    • rouault : r13274 (post-beta1), Ubuntu 7.10 i386, autotest fine, openev fine on all available operationnal datasets (all = just one ;-))
  • RPFTOC
    • rouault : r13274 (post-beta1), Ubuntu 7.10 i386, gdalinfo/openev fine on all available operationnal datasets
  • Spot DIMAP
    • rouault : r13274 (post-beta1), Ubuntu 7.10 i386, autotest fine
  • ENVI
    • rouault : r13274 (post-beta1), Ubuntu 7.10 i386, autotest fine
    • warmerdam : post-beta1 FWTools linux interactive testing, all fine.
  • ERS (ERMapper):
    • warmerdam : post-beta1 FWTools linux&win32, interactive testing, all fine.
  • INGR (Intergraph Raster)
    • rouault : r13274 (post-beta1), Ubuntu 7.10 i386, autotest fine
  • Leveller
    • rouault : r13274 (post-beta1), Ubuntu 7.10 i386, autotest fine
  • NITF (needs testing on exotic files)
    • warmerdam: autotest succeeding on all buildbot platforms)
    • rouault : r13274 (post-beta1), Ubuntu 7.10 i386, autotest fine. On ftp://download.osgeo.org/gdal/data/nitf
      • nitf2.0 : gdalinfo fine except U_2001d.ntf (ERROR 4: `../../nitf/nitf2.0/U_2001d.ntf.aux.xml' not recognised as a supported file format) and same error with U_2001e.ntf, U_2005a.ntf, U_2010a.ntf, U_2015a.ntf, U_2020a.ntf.
        gdalinfo U_4007a.ntf : ERROR 1: libjpeg: Unsupported JPEG data precision 12
      • nitf2.1 : gdalinfo and openev fine on all
  • NetCDF
    • warmerdam: autotest succeeding on i32 linux (telascience) buildbot.
    • rouault : r13274 (post-beta1), Ubuntu 7.10 i386, autotest fine
  • SRTMHGT
    • rouault : r13274 (post-beta1), Ubuntu 7.10 i386, gdalinfo/openev fine on all available operationnal datasets
  • WCS
    • warmerdam: autotest succeeding on MacOS X (epimetheus) and i32 linux (telascience).
    • rouault : r13274 (post-beta1), Ubuntu 7.10 i386, autotest fine
  • WMS
    • warmerdam: autotest succeeding on MacOS X (epimetheus) and i32 linux (telascience).
    • rouault : r13274 (post-beta1), Ubuntu 7.10 i386, autotest fine
  • HTTP
    • kyngchaos: must disable DODS (GDAL_SKIP) for this to test correctly
  • Other

Vector (OGR)

  • OCI (Oracle)
    • kyngchaos: OCI libraries only available for PPC OSX, I gave up on OCI long ago.
  • KML
    • rouault : r13274 (post-beta1), Ubuntu 7.10 i386, autotest fine
  • GML
    • rouault : r13274 (post-beta1), Ubuntu 7.10 i386, autotest fine
  • GPX
    • rouault : r13274 (post-beta1), Ubuntu 7.10 i386, autotest fine, ogrinfo -ro -al fine on big GPX (50 MB, 117 000 features)
  • GeoJSON
    • rouault : r13274 (post-beta1), Ubuntu 7.10 i386, autotest fine
  • GMT
    • no reports
  • GRASS
    • no reports
  • BNA (Atlas)
    • rouault : r13274 (post-beta1), Ubuntu 7.10 i386, autotest fine
  • Interlis
    • no reports
  • MapInfo? (tab and midmif)
    • no reports
  • DODS
    • kyngchaos: OSX - have never been able to test successfully, autotest test server never responds.
  • PG (Postgres/PostGIS)
    • no reports
  • Informix
    • no reports
  • Other

Last modified 13 years ago Last modified on Dec 18, 2007, 1:28:02 PM