Opened 14 years ago

Closed 12 years ago

#914 closed defect (worksforme)

MrSID fails in MapServer

Reported by: richard.greenwood@… Owned by: warmerdam
Priority: high Milestone:
Component: GDAL_Raster Version: unspecified
Severity: normal Keywords:
Cc:

Description (last modified by hobu)

MapServer (from FWTools 0.9.9 windows binary distribution) displays the
following error when attempting to dispaly a MrSID file:

msDrawMap(): Image handling error. Failed to draw layer named 'color2004'.
MrSIDRasterBand::IRasterIO(): Failed to load image. mg2 somethi: Unable to
access file. GDALRasterIO() failed: drawGDAL() 

For this sid file, gdalinfo reports:

Driver: MrSID/Multi-resolution Seamless Image Database (MrSID)
Size is 95930, 104860
Coordinate System is `'
Origin = (404380.000000,4962530.000000)
Pixel Size = (1.00000000,-1.00000000)
Metadata:
  IMAGE__STATISTICS_MIN=0,0,0
  IMAGE__STATISTICS_MAX=255,255,255
  IMAGE__STATISTICS_MEAN=60.094310,65.119011,63.999153
  IMAGE__STATISTICS_STANDARD_DEVIATION=53.808704,53.479578,50.239969
  IMAGE__BITS_PER_SAMPLE=8
  IMAGE__INPUT_FORMAT=GeoTIFF
  GEOTIFF_NUM__1025__GTRasterTypeGeoKey=1
  GEOTIFF_CHAR__GTRasterTypeGeoKey=RasterPixelIsArea
  GEOTIFF_NUM__1026__GTCitationGeoKey=written by OrthoVista Version 4.0.0
  IMAGE__INPUT_FILE_SIZE=23922773305.000000
  IMAGE__INPUT_NAME=D:\Source\Fremont\n_4311101_ne_12_1_2004mmdd.tif, D:\Source\
Fremont\n_4311101_nw_12_1_2004mmdd.tif

<snip>
   Dozens of source tiff files listed here
</snip>

  IMAGE__COMPRESSION_VERSION=2,0,0
  IMAGE__TARGET_COMPRESSION_RATIO=50.000000
  IMAGE__COMPRESSION_NLEV=9
  IMAGE__COMPRESSION_WEIGHT=4.000000
  IMAGE__COMPRESSION_GAMMA=2.000000
  IMAGE__COMPRESSION_BLOCK_SIZE=512
  IMAGE__CREATION_DATE=Fri Sep 17 08:22:00 2004

  IMAGE__WIDTH=95930
  IMAGE__HEIGHT=104860
  IMAGE__COLOR_SCHEME=0
  IMAGE__DATA_TYPE=0
  IMAGE__XY_ORIGIN=404380.500000,4962529.500000
  IMAGE__X_RESOLUTION=1.000000
  IMAGE__Y_RESOLUTION=1.000000
Corner Coordinates:
Upper Left  (  404380.000, 4962530.000)
Lower Left  (  404380.000, 4857670.000)
Upper Right (  500310.000, 4962530.000)
Lower Right (  500310.000, 4857670.000)
Center      (  452345.000, 4910100.000)
Band 1 Block=1024x128 Type=Byte, ColorInterp=Red
Band 2 Block=1024x128 Type=Byte, ColorInterp=Green
Band 3 Block=1024x128 Type=Byte, ColorInterp=Blue


The MapServer requested extent and render size:
SIZE 645 485
EXTENT 404380 4857670 500310 4962530

The sid file can be downloaded from:
   http://inside.uidaho.edu/asp/NAIP2004.asp
I was using "Fremnot County" (400MB) but I encountered the same error with
"Teton County" (100MB) which is also available from the URI above.

I was able to display this sid file about a year ago in the mapserver/gdal
version at that time, however performance was very slow.

I attempted to display the sid file in OpenEV, FWTools version 0.9.9. I let it
run for about 2 hours, in which time it had displayed about 1/2 of the image.

Do not hesitate to contact me if there is additional information or help that I
can provide.

Thanks,
Rich

Change History (4)

comment:1 Changed 14 years ago by warmerdam

My first efforts to reproduce this on Linux with Mapserver on
~/data/mrsid/cen1.sid failed.  I could zoom in and out to any degree without 
any errors.  Performance was a bit eratic (from about 1s to about 3s) but 
seemed to settle down when the portion of the image was paged into the disk 
cache. 

I am downloading Teton county and will try again, moving to win32 and FWTools
if I can't reproduce it on linux.

Rich ... could you confirm the exact version of the MrSID DLLs you
used? 



comment:2 Changed 14 years ago by richard.greenwood@…

DLL version info:

In FWTools0.9.9\bin:
  gdal_fw.dll 1.3.0.0b1, FWTools 0.9.9
  lti_dsdk_dll.dll 5.0.6.955
In FWTools0.9.9\plugins\mrsid\bin
  lti_dsdk_cdll.dll
  lti_dsdk_dll.dll
Neither of these files have version info in their properties, but intrernally I
found a string: "SDK Version 4.0.10.720.Bob_713_br" for whatever that's worth.

comment:3 Changed 13 years ago by hobu

Rich,

Are you still having trouble with these MrSID files with the latest SDK that's in either MS4W or FWTools?  

Howard

comment:4 Changed 12 years ago by hobu

Description: modified (diff)
Resolution: worksforme
Status: assignedclosed

Closing for lack of activity....

Note: See TracTickets for help on using tickets.