Opened 15 years ago

Closed 13 years ago

Last modified 11 years ago

#823 closed defect (fixed)

GDAL compiling under GRASS 6.0

Reported by: usenet@… Owned by: warmerdam
Priority: normal Milestone: 1.4.2
Component: GDAL_Raster Version: unspecified
Severity: normal Keywords: grass
Cc: Mateusz Łoskot

Description (last modified by Mateusz Łoskot)

I can't compile --with-grass=ARG for GDAL 1.2.6 and GRASS 6.0 (its looking for grass5 libraries).

As such, I can't use r.out.gdal and related gdal operations from withing GRASS 6. Help!

Change History (7)

comment:1 Changed 14 years ago by warmerdam

Jonathan, 

At long last, I have tried to reproduce this and was unable to. 

Could you be more specific about why you think it is failing?

In my case I configured with:

    --with-grass=/usr/local/grass-6.0.0

And it worked fine. 



comment:2 Changed 14 years ago by tzhai2002@…

(In reply to comment #1)
> Jonathan, 
> 
> At long last, I have tried to reproduce this and was unable to. 
> 
> Could you be more specific about why you think it is failing?
> 
> In my case I configured with:
> 
>     --with-grass=/usr/local/grass-6.0.0
> 
> And it worked fine. 
> 
> 
> 

Hi, Frank,
   Actually, I have similar problem on my 
Machine hardware:   sun4u
OS version:         5.9
Processor type:     sparc
Hardware:           SUNW,Sun-Fire-V440

   I don't have system admin privi, hence I installed GRASS 6 locally and it is
installed in a directory grass-6.0.1/, I am also aware of the cyclic dependence
of GRASS and GDAL, I am down to the last step of recompiling GDAL to be
--with-grass, but no matter what I do with that flag, it just keep saying that
it can't find the GRASS libraries.

   all the grass libs are installed at: dist.sparc-sun-solaris2.9/ directory
under the grass-6.0.1/ folder, everything is in place, but when I set 
--with-grass=$HOME/grass-6.0.1/dist.sparc-sun-solaris2.9/      or
--with-grass=$HOME/grass-6.0.1/dist.sparc-sun-solaris2.9       and/or
--with-libgrass=$HOME/grass-6.0.1/dist.sparc-sun-solaris2.9/lib

and other combinations, it keeps saying so and so directory is requested, but no
library is found!

  Could you help?
  Thanks!


comment:3 Changed 13 years ago by Mateusz Łoskot

Description: modified (diff)

comment:4 Changed 13 years ago by Mateusz Łoskot

Frank,

I think this ticket can be reviewed againt more recent reports about GRASS support and grass-plugin. Perhaps it can be closed.

comment:5 Changed 13 years ago by warmerdam

Cc: Mateusz Łoskot added
Milestone: 1.4.2
Priority: highnormal
Severity: majornormal

Mateusz,

I think this is already dealt with. Could you verify that building the grass driver into GDAL still works with 1.4.x and trunk and then close this report?

comment:6 Changed 13 years ago by Mateusz Łoskot

Resolution: fixed
Status: assignedclosed

I confirm building GDAL with GRASS support, using --with-grass option, works for me.

I'm closing this ticket as fixed.

comment:7 Changed 11 years ago by Mateusz Łoskot

Keywords: grass added
Note: See TracTickets for help on using tickets.