Opened 15 years ago

Closed 13 years ago

#716 closed defect (fixed)

HDF Driver confused by drive specifies

Reported by: warmerdam Owned by: dron
Priority: normal Milestone:
Component: GDAL_Raster Version: unspecified
Severity: normal Keywords:
Cc:

Description (last modified by warmerdam)

Requests for datasets with embedded drive specifiers fails like this:

C:\warmerda>gdalinfo HDF4_EOS:EOS_SWATH:"n:\data\hdf\MOD07_L2.A2000110.0220.002.
2000196104217.hdf":mod07:Quality_Assurance_Infrared
ERROR 4: `HDF4_EOS:EOS_SWATH:n:\data\hdf\MOD07_L2.A2000110.0220.002.200019610421
7.hdf:mod07:Quality_Assurance_Infrared' does not exist in the file system,
and is not recognised as a supported dataset name.

GDALOpen failed - 4
`HDF4_EOS:EOS_SWATH:n:\data\hdf\MOD07_L2.A2000110.0220.002.2000196104217.hdf:mod
07:Quality_Assurance_Infrared' does not exist in the file system,
and is not recognised as a supported dataset name.

Open GDAL Datasets:
  1 N DriverIsNULL 512x512x0

The same thing, without the n: in the filename works fine (assuming you are
already on the n: drive).  The problem is presumably the colon in the drive
specifier confusing the colon based parsing.

Change History (1)

comment:1 Changed 13 years ago by warmerdam

Description: modified (diff)
Priority: highnormal
Resolution: fixed
Status: newclosed

I think this is a duplicate of ticket #1351, and was fixed for 1.3.2 or perhaps 1.4.0 as long as appropriate backslashes are used to protect the double quotes on the DOS commandline.

Note: See TracTickets for help on using tickets.