Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#6580 closed defect (fixed)

GTiffDataset::Finalize() should flush dirty buffer before filling empty tiles

Reported by: Even Rouault Owned by: Even Rouault
Priority: normal Milestone:
Component: GDAL_Raster Version: unspecified
Severity: normal Keywords: gtiff
Cc:

Description

In some scenarios in trunk (using Create(), with nodata value, and non power of 2 depth), data can be lost when writing GeoTIFF. The issue was latent before but couldn't cause data loss, just (some) wasted storage in case of compressed files.

Change History (3)

comment:1 Changed 3 years ago by Even Rouault

Note: the issue could arise since r34201 "GTiff: when writing missing blocks (ie non SPARSE case), use the nodata value when defined"

comment:2 Changed 3 years ago by Even Rouault

Resolution: fixed
Status: newclosed

In 34539:

GTiff: fix suboptimal behaviour before regarding flushing of working buffer (fixes #6580)

comment:3 Changed 3 years ago by Even Rouault

trunk r34538 "GTiff: fix trunk r34201 regression, and suboptimal behaviour before regarding flushing of working buffer (#6580)"

Note: See TracTickets for help on using tickets.