Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6446 closed defect (duplicate)

gdal crash on many pdf files

Reported by: pierstitus Owned by: warmerdam
Priority: normal Milestone:
Component: default Version: 1.11.2
Severity: normal Keywords: pdf crash
Cc:

Description

Many pdf files cause gdal tools to crash, for example gdalinfo, but also other applications using gdal, for example QGIS (https://hub.qgis.org/issues/13439).

Backtrace:

#0  0x00007ffff5bae03d in PDFDoc::isLinearized(bool) () from /usr/lib/x86_64-linux-gnu/libpoppler.so.52
#1  0x00007ffff5bb258b in PDFDoc::getNumPages() () from /usr/lib/x86_64-linux-gnu/libpoppler.so.52
#2  0x00007ffff5bb2601 in PDFDoc::~PDFDoc() () from /usr/lib/x86_64-linux-gnu/libpoppler.so.52
#3  0x00007ffff73bfdc8 in ?? () from /usr/lib/libgdal.so.1
#4  0x00007ffff73c3376 in ?? () from /usr/lib/libgdal.so.1
#5  0x00007ffff73c3749 in ?? () from /usr/lib/libgdal.so.1
#6  0x00007ffff74b50ec in GDALClose () from /usr/lib/libgdal.so.1
#7  0x0000000000406073 in ?? ()
#8  0x00007ffff6360a40 in __libc_start_main (main=0x402a40, argc=3, argv=0x7fffffffdde8, init=<optimized out>, 
    fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffffffddd8) at libc-start.c:289
#9  0x0000000000402a79 in ?? ()

I'm using Ubuntu 15.04 GDAL 1.11.2+dfsg-3ubuntu3 libpoppler52 0.33.0-0ubuntu3

Attachments (1)

gdal_crash.pdf (221.9 KB) - added by pierstitus 5 years ago.
example file that crashes gdal (e.g. gdalinfo gdal_crash.pdf)

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by pierstitus

Attachment: gdal_crash.pdf added

example file that crashes gdal (e.g. gdalinfo gdal_crash.pdf)

comment:1 Changed 5 years ago by Even Rouault

Resolution: duplicate
Status: newclosed

This is a problem in the Ubuntu packaging. They only picked up one patch of 2 to have support for Poppler >= 0.31.0 (particularly they should apply https://trac.osgeo.org/gdal/changeset/28956). This is a duplicate of #6118. The issue should be reported to Ubuntu launchpad.

comment:2 Changed 5 years ago by pierstitus

Ok, thanks, then it is fixed in Ubuntu 16.04 which arrives later this month, good enough.

Anyway it is a nice example of how an ugly hack (https://trac.osgeo.org/gdal/changeset/20904) can cause problems five years later. And this fix is even more hacky, I'm impressed! But I guess you did your best to find a better solution for the original cross heap problem, and concluded that such a hack is the best solution for now.

Anyway thanks for all the good work, life would be hard without GDAL!

comment:3 Changed 5 years ago by Even Rouault

Yes, there are ugly stuff in that PDF driver. Poppler C++ API hasn't been really designed for external consumption.

Note: See TracTickets for help on using tickets.