Opened 2 years ago

Closed 2 years ago

Last modified 21 months ago

#5999 closed defect (fixed)

GDAL 2.0.0RC1 produces too large compressed GeoTIFF (sometimes)

Reported by: Even Rouault Owned by: Even Rouault
Priority: normal Milestone: 2.0.0
Component: default Version: unspecified
Severity: normal Keywords:
Cc:

Description

When converting from a file whose block size is larger than the target block size (for example 256x256 --> strip ), with interleave=pixel output, a strip can get rewritten several times, leading to a too large file. For example compressing a tiled BMNG file to DEFLATE stripped can generate a file of 707 MB instead of 486 MB. This is a 2.0 regression due to changes in GDALRasterBlock::Internalize(). While investigating that, there was also a older defect of the GeoTIFF driver, that was hard to trigger, where consecutive IWriteBlock() of same block coord cordinates but in different bands lead to the buffer being flushed too early

Change History (2)

comment:1 Changed 2 years ago by Even Rouault

Milestone: 2.0
Resolution: fixed
Status: newclosed

trunk r29333, branches/2.0 r29334 "GTiff/block cache: fix creation of pixel interleaved multiband files (2.0 regression, #5999)"

comment:2 Changed 21 months ago by Even Rouault

Milestone: 2.02.0.0

Milestone renamed

Note: See TracTickets for help on using tickets.