Opened 9 years ago

Closed 9 years ago

#5222 closed defect (duplicate)

Undefined symbol "_environ", referenced from: _CPLSpawnAsync in cpl_spawn.o

Reported by: peifer Owned by: warmerdam
Priority: normal Milestone:
Component: default Version: svn-trunk
Severity: normal Keywords: macport
Cc:

Description

The most recent change in cpl_spawn.cpp [26316] results into a regression for Mac OSX, see (1), (2) and (3). My installation finishes successfully after reverting this change locally.

(1)

...
libtool: link: /usr/bin/clang++ -dynamiclib -o .libs/libgdal.1.dylib ...
clang: warning: argument unused during compilation: '-pthread'
Undefined symbols for architecture x86_64:
  "_environ", referenced from:
      _CPLSpawnAsync in cpl_spawn.o
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[1]: *** [libgdal.la] Error 1
make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_gis_gdal/gdal/work/gdal-1.10.1'
make: *** [check-lib] Error 2

(2) https://build.macports.org/builders/buildports-lion-x86_64/builds/13866/steps/compile/logs/stdio

(3) https://build.macports.org/builders/buildports-snowleopard-x86_64/builds/20226/steps/compile/logs/stdio

Change History (2)

comment:1 by peifer, 9 years ago

It looks my ticket is related to ticket:5197

comment:2 by peifer, 9 years ago

Resolution: duplicate
Status: newclosed

This is indeed a duplicate of #5197

Note: See TracTickets for help on using tickets.