Opened 18 years ago

Last modified 18 years ago

#514 closed defect (fixed)

compile errors GDAL 1.2 Mac OS X (10.3.2)

Reported by: smitch@… Owned by: warmerdam
Priority: high Milestone:
Component: GDAL_Raster Version: unspecified
Severity: normal Keywords:


I'm no longer able to compile GDAL on my Macs (was building using CVS version a
couple of weeks ago), although the Linux still gets through a build fine.  I've
tried both the CVS version and the "beta" tarball, in case the change crept in
there in between.

gcc 3.3, Darwin-powerpc 7.2.0
configure --without-python (tried a bunch of other versions too, all resulted in
the same error, though).

The error:

 g++ -Wall -O2 -I../../port -I../../gcore -I../../ogr -I../../port -c
btdataset.cpp  -fno-common -DPIC -o ../o/.libs/btdataset.o
btdataset.cpp: In member function `virtual CPLErr BTRasterBand::IReadBlock(int, 
   int, void*)':
btdataset.cpp:133: error: `nWordSize' undeclared (first use this function)
btdataset.cpp:133: error: (Each undeclared identifier is reported only once for 
   each function it appears in.)
make[2]: *** [../o/btdataset.o] Error 1
make[1]: *** [raw-install-obj] Error 2
make: *** [frmts-target] Error 2

Frank, in checking list archives for prior reports of this, I noticed that you
asked recently about getting an account on an OS X machine so that you could
test/diagnose builds.  If you could still use this, I'd be happy to provide.

Scott Mitchell

Change History (3)

comment:1 by warmerdam, 18 years ago


There are two lines in gdal/frmts/raw/btdataset.cpp that call GDALSwapWords().
Could you alter them to pass nDataSize as the last argument?

I just rewrote this module and I only tested it on LSB systems.  

comment:2 by smitch@…, 18 years ago

That was it, rest compiled cleanly, thanks.

comment:3 by warmerdam, 18 years ago

Change committed. 

Beta tarball replaced with fixed version.

Note: See TracTickets for help on using tickets.