Opened 8 years ago

Closed 4 years ago

#5112 closed defect (fixed)

Nmake clean does not clean everything

Reported by: bartoli Owned by: warmerdam
Priority: normal Milestone:
Component: default Version: unspecified
Severity: normal Keywords:
Cc:

Description

Hi, I noticed that 'nmake clean' leaves some .obj undeleted. The problem was already there for GDAl1.9.x, and is in a few more folders in 1.10 :

  • frmts/netcdf
  • ogr/ogrsf_frmts/dwg
  • ogr/ogrsf_frmts/libkml
  • ogr/ogrsf_frmts/ods
  • ogr/ogrsf_frmts/xlsx

I noticed it, because i dit the following :

  • use /MDd for GDal debug build instead of the default/MD
  • build a debug build, then a release build

--> the release build got LNK2038 errors because the undeleted .obj filesused the debug rntime library and the recompiled files used the release build, so i got errors at the final library linking You will not get my problem if you keep using /MD for GDAL debug, but the cleaning should be done properly anyways

Change History (2)

comment:1 Changed 8 years ago by Even Rouault

Any patch for that ?

comment:2 Changed 4 years ago by Even Rouault

Resolution: fixed
Status: newclosed

Cannot be reproduced anymore with latest trunk

Note: See TracTickets for help on using tickets.