Opened 10 years ago

Closed 10 years ago

#4906 closed defect (duplicate)

gdal_translate fails with recent GeoEye imagery

Reported by: jwderos Owned by: warmerdam
Priority: normal Milestone:
Component: default Version: 1.9.1
Severity: normal Keywords:
Cc:

Description

I am experiencing the following problem with recent GeoEye imagery for both the original GeoEye spacecraft and the recently acquired IKONOS. This only happens with GDAL 1.9.1. It works correctly with GDAL 1.8.1.

I have NTF files with WKT that looks like: PROJCS["unnamed",

GEOGCS["WGS 84",

DATUM["WGS_1984",

SPHEROID["WGS 84",6378137,298.257223563,

AUTHORITY["EPSG","7030"]],

TOWGS84[0,0,0,0,0,0,0], AUTHORITY["EPSG","6326"]],

PRIMEM["Greenwich",0,

AUTHORITY["EPSG","8901"]],

UNIT["degree",0.0174532925199433,

AUTHORITY["EPSG","9108"]],

AUTHORITY["EPSG","4326"]],

PROJECTIONTransverse_Mercator, PARAMETER["latitude_of_origin",0], PARAMETER["central_meridian",-75], PARAMETER["scale_factor",0.9996], PARAMETER["false_easting",500000], PARAMETER["false_northing",0]]

After: gdal_translate -of GTiff -ot UInt16 5v121111m0012287264b222000100072m_001010993.ntf GE_gdal_191.tif

it looks like this: PROJCS["unnamed",

GEOGCS["WGS 84",

DATUM["WGS_1984",

SPHEROID["WGS 84",6378137,298.257223563,

AUTHORITY["EPSG","7030"]],

AUTHORITY["EPSG","6326"]],

PRIMEM["Greenwich",0], UNIT["degree",0.0174532925199433], AUTHORITY["EPSG","4326"]],

PROJECTIONTransverse_Mercator, PARAMETER["latitude_of_origin",0], PARAMETER["central_meridian",-75], PARAMETER["scale_factor",0.9996], PARAMETER["false_easting","inf"], PARAMETER["false_northing","nan"], UNIT["degree minute second hemisphere",0,

AUTHORITY["EPSG","9108"]]]

And subsequent operations fail on the output file.

These are restricted files so I can't attach them. I can post them and e-mail a URL for download.

Change History (1)

comment:1 by Even Rouault, 10 years ago

Resolution: duplicate
Status: newclosed

This was a regression of 1.9.1 (see #4677) that is fixed in 1.9.2

Note: See TracTickets for help on using tickets.