Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#4718 closed defect (worksforme)

FAILURE: Unable to open datasource with the following drivers.

Reported by: kyunghyok Owned by: warmerdam
Priority: normal Milestone:
Component: OGR_SRS Version: unspecified
Severity: major Keywords:
Cc:

Description

FAILURE: Unable to open datasource `C:\TEMP\input\ggdmAll.gml' with the following drivers. Using Ogr2Ogr.exe to convert .gml to shapefile returns error on ogr2ogr.log

When I use more than 40 feature classes on the gml that returned from WFS service, ogr2ogr failed to convert and return with error indicated above. If I use less than 30 feature classes, it works fine. so, in order to convert, I had to break feature classes to less than 30 in one .gml file.

Change History (6)

comment:1 Changed 9 years ago by Even Rouault

Are you really using GDAL 1.5.X ? If so, I'd suggest you to upgrade to a more recent version. The GML driver has changed a lot since then !

comment:2 Changed 9 years ago by kyunghyok

Milestone: 1.5.51.6.4

comment:3 Changed 9 years ago by Even Rouault

Changing the milestone will not help (it is dubious that there will be a 1.6.4 release by the way). Could you give more details and/or provide the gml file ? I'd suggest using a recent version such as GDAL 1.9.0 or GDAL 1.9.1.

comment:4 Changed 9 years ago by kyunghyok

I hope I can attach gml file, but I don't have permission to upload file. I also used 1.6 executable and received same result that's why I changed to 1.6.4

comment:5 Changed 9 years ago by Even Rouault

Resolution: worksforme
Status: newclosed

I'm afraid we cannot do more without more information. The best advice I can give is to try GDAL 1.9.0 or later, and if it still does not work, try to give a way to reproduce.

comment:6 Changed 8 years ago by Even Rouault

Milestone: 1.6.4

Milestone 1.6.4 deleted

Note: See TracTickets for help on using tickets.